Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
The BB10 WebWorks Framework is packaged within an application BAR file to run on a BB10 device (or simulator)
JavaScript C++ HTML CSS Makefile

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
build
dependencies
ext
lib
test
.csslintrc
.gitignore
.gitmodules
.jshintignore
.jshintrc
Jakefile
Makefile
README.md
configure
dist.xml
licenses.txt
package.json
pom.xml
version

README.md

BB10-WebWorks-Framework

Prerequisites

  1. Install node and npm and add to path. Download Here
  2. Install BlackBerry Native SDK. Download Here
  3. Install CMake. Download Here
  4. Add BlackBerry Native SDK bin directory to path. i.e. Installation Directory\host\win32\x86\usr\bin
  5. Add CMake bin to path. i.e. Installation Directory\bin
  6. Add Git bin to path. i.e. Installation Directory\bin [Windows only]

Setup and Build

  1. git clone https://github.com/blackberry-webworks/BB10-WebWorks-Framework.git
  2. cd BB10-WebWorks-Framework
  3. git checkout next
  4. Configuration:
    • For Mac: ./configure
    • For Windows: bash configure (run from command prompt)
  5. Run 'jake test' and check that jake runs and completes
  6. Setup bbndk environment variable
    • For Mac: Add "source installation directory here/bbndk-env.sh" to your bash profile
    • For Windows: Run BBNDK Installation Directory\bbndk-env.bat.
  7. Run 'jake' or 'jake build' and check that the output folder is created under the "target/zip" subfolder. If on windows, run jake from command prompt.

Running Tests

  1. jake test - to run js tests using nodejs
  2. jake native-test - to run native unit tests
    1. To setup run jake upload-ssh-key[,] eg. jake upload-ssh-key[169.254.0.1,~/.ssh/id_rsa.pub]
    2. To run the tests use jake native-test[,] eg. jake native-test[device,169.254.0.1]

Dependencies

  1. cpplint is used for linting Cpp code. Source code is located under dependencies/cpplint
  2. JNEXT 1.0.8.3 is used to build extensions. Original source of JNEXT was downloaded from here - http://jnext.googlecode.com/files/jnext-src-1.0.8.3.zip Modifications are available in source code and located udner dependencies/jnext_1_0_8_3
Something went wrong with that request. Please try again.