bbwp.properties will list JDK 1.7 as Java version #82

Open
garettB opened this Issue Dec 13, 2011 · 0 comments

Comments

Projects
None yet
1 participant
@garettB

garettB commented Dec 13, 2011

BlackBerry WebWorks for smartphone requires JDK version 1.6, 1.7 is not currently supported. If you have JDK 1.7 installed, however, the installer will pick up on this and set it to be the version used by WebWorks in the bbwp.properties file.

This was tested using:
Windows 7 64-bit
BlackBerry WebWorks SDK 2.2.0.15
Java SDK v1.7.0_02 (C:\Program Files (x86)\Java\jdk1.7.0_02)

Ideally the installer would either choose a version of JDK 1.6 that is installed or, if a compatible Java version could not be found, display an error message alerting the user to install a supported version.

Cheers,
Garett

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment