Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Sometimes it's possible to have two radio buttons highlighted at once #327

Closed
mdandrea opened this Issue · 10 comments

3 participants

@mdandrea

I'm using the following code to create radio buttons one on top of the other:

                    <table>
                        <tr>
                            <td class="column1"><input type=radio name="ppgtype" id="publicradio" value="public" checked=true onchange="sample.pushcapture.publicPPG()" /></td>
                            <td class="column2">Public/BIS</td>
                        </tr>
                    </table>
                    <table>
                        <tr>
                            <td class="column1"><input type=radio name="ppgtype" id="enterpriseradio" value="enterprise" onchange="sample.pushcapture.enterprisePPG()" /></td>
                            <td class="column2">Enterprise/BES</td>
                        </tr>
                    </table>

In spite of the fact that they have the same name of "ppgtype", it it sometimes possible to select both radio buttons at once.

I can send you a screenshot of this.

Not sure what the root cause of it is. Has anyone else encountered this?

Matt

@tneil
Owner

Are they stacked one on top of the other, or side by side.. right now they have only been designed to be stacked one on top of the other

@mdandrea
@nunodonato

Are you experiencing this in Ripple or in the DevAlpha/Simulator?

@mdandrea
@nunodonato

Unfortunately my DevAlpha was taken away from me, so I can't test it now. In the simulator it worked fine, but I have the same problem with Ripple (different function is called when the user presses the radio button).

@tneil
Owner

I was able to reproduce this once.. but I'm having a hard time trying to find a consistent way to cause the issue. I'm wondering if it has to do with click vs touch events in the browser..

@mdandrea

Just saw this again on R9 build 1675. Still hard to reproduce though. :(

@tneil
Owner

yup.. I can't seem to find a pattern to it yet. Likely some missed event of some sort.

@tneil tneil referenced this issue from a commit
Tim Neil fix for radio button issue #327 f8f067a
@tneil
Owner

WooHoo!! I believe this one is now fixed

@tneil tneil closed this
@mdandrea

Yeah! :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.