Permalink
Browse files

v0.0.3

  • Loading branch information...
blackwinter committed Apr 2, 2012
1 parent a64fd78 commit de25501f03684e85f2b7b559d85d1ecaa482726d
Showing with 10 additions and 5 deletions.
  1. +5 −0 ChangeLog
  2. +1 −1 lib/libcdb/version.rb
  3. +4 −4 libcdb-ruby.gemspec
View
@@ -1,5 +1,10 @@
= Revision history for libcdb-ruby
+== 0.0.3 [2012-04-02]
+
+* Fixed linking error on Mac OS X. (Issue #1 reported by minaguib)
+* Some internal refactoring.
+
== 0.0.2 [2012-01-20]
* Refactored C code to DRY.
View
@@ -6,7 +6,7 @@ module Version
MAJOR = 0
MINOR = 0
- TINY = 2
+ TINY = 3
class << self
View
@@ -2,20 +2,20 @@
Gem::Specification.new do |s|
s.name = "libcdb-ruby"
- s.version = "0.0.2"
+ s.version = "0.0.3"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Jens Wille"]
- s.date = "2012-01-20"
+ s.date = "2012-04-02"
s.description = "Ruby bindings for CDB Constant Databases."
s.email = "jens.wille@uni-koeln.de"
s.extensions = ["ext/libcdb/extconf.rb"]
s.extra_rdoc_files = ["README", "COPYING", "ChangeLog", "ext/libcdb/libcdb.c", "ext/libcdb/ruby_cdb.c", "ext/libcdb/ruby_cdb_reader.c", "ext/libcdb/ruby_cdb_writer.c"]
s.files = ["lib/libcdb-ruby.rb", "lib/libcdb/version.rb", "lib/cdb.rb", "lib/libcdb.rb", "ChangeLog", "COPYING", "README", "Rakefile", "TODO", "ext/libcdb/ruby_cdb_writer.h", "ext/libcdb/ruby_cdb.c", "ext/libcdb/ruby_libcdb.h", "ext/libcdb/ruby_cdb_reader.c", "ext/libcdb/ruby_cdb.h", "ext/libcdb/ruby_cdb_writer.c", "ext/libcdb/extconf.rb", "ext/libcdb/ruby_cdb_reader.h", "ext/libcdb/libcdb.c", "ext/libcdb/libcdb_ruby.def", "spec/libcdb/writer_spec.rb", "spec/libcdb/reader_spec.rb", "spec/spec_helper.rb", ".rspec"]
s.homepage = "http://github.com/blackwinter/libcdb-ruby"
- s.rdoc_options = ["--main", "README", "--all", "--charset", "UTF-8", "--title", "libcdb-ruby Application documentation (v0.0.2)", "--line-numbers"]
+ s.rdoc_options = ["--title", "libcdb-ruby Application documentation (v0.0.3)", "--line-numbers", "--main", "README", "--all", "--charset", "UTF-8"]
s.require_paths = ["lib"]
- s.rubygems_version = "1.8.15"
+ s.rubygems_version = "1.8.21"
s.summary = "Ruby bindings for CDB Constant Databases."
if s.respond_to? :specification_version then

0 comments on commit de25501

Please sign in to comment.