Permalink
Browse files

Replace epath by path; move awesome_print to extra.

  • Loading branch information...
1 parent aa3f8c9 commit 9db126c907ed105b869bad8f14bd675c762cfc05 @blambeau committed Nov 29, 2012
Showing with 20 additions and 12 deletions.
  1. +5 −2 Gemfile
  2. +2 −2 Gemfile.lock
  3. +7 −2 lib/wlang/command.rb
  4. +1 −1 lib/wlang/loader.rb
  5. +1 −1 spec/spec_helper.rb
  6. +2 −2 wlang.gemspec
  7. +2 −2 wlang.noespec
View
@@ -4,11 +4,14 @@ group :runtime do
gem "citrus", "~> 2.4.1"
gem "temple", "~> 0.4.0"
gem "quickl", "~> 0.4.3"
- gem "awesome_print", "~> 1.0.2"
- gem "epath", ">= 0.2"
+ gem "path", "~> 1.3"
gem "backports", "~> 2.6"
end
+group :extra do
+ gem "awesome_print", "~> 1.0.2"
+end
+
group :development do
gem "tilt", "~> 1.3"
gem "rake", "~> 0.9.2"
View
@@ -15,7 +15,7 @@ GEM
bluecloth (2.2.0)
citrus (2.4.1)
diff-lcs (1.1.3)
- epath (0.2.0)
+ path (1.3.1)
quickl (0.4.3)
rack (1.4.1)
rack-protection (1.2.0)
@@ -44,7 +44,7 @@ DEPENDENCIES
bluecloth (~> 2.2.0)
bundler (~> 1.0)
citrus (~> 2.4.1)
- epath (>= 0.2)
+ path (~> 1.3)
quickl (~> 0.4.3)
rack-test (~> 0.6.1)
rake (~> 0.9.2)
View
@@ -46,8 +46,13 @@ def execute(argv)
install(argv)
if @ast
- require 'awesome_print'
- ap @template.to_ast
+ begin
+ require 'awesome_print'
+ ap @template.to_ast
+ rescue LoadError
+ puts "HINT: install the 'awesome_print' gem for pretty output!"
+ puts @template.to_ast.inspect
+ end
end
with_output do |output|
View
@@ -1,5 +1,5 @@
require "citrus"
require "temple"
require "quickl"
-require "epath"
+require "path"
require 'backports' if RUBY_VERSION < "1.9"
View
@@ -1,4 +1,4 @@
-require 'epath'
+require 'path'
$root_folder ||= Path.backfind('.[Rakefile]')
require 'tilt'
View
@@ -123,6 +123,7 @@ Gem::Specification.new do |s|
# One call to add_development_dependency('gem_name', 'gem version requirement')
# for each development dependency. These gems are required for developers
#
+ s.add_development_dependency("awesome_print", "~> 1.0.2")
s.add_development_dependency("tilt", "~> 1.3")
s.add_development_dependency("rake", "~> 0.9.2")
s.add_development_dependency("bundler", "~> 1.0")
@@ -134,8 +135,7 @@ Gem::Specification.new do |s|
s.add_dependency("citrus", "~> 2.4.1")
s.add_dependency("temple", "~> 0.4.0")
s.add_dependency("quickl", "~> 0.4.3")
- s.add_dependency("awesome_print", "~> 1.0.2")
- s.add_dependency("epath", ">= 0.2")
+ s.add_dependency("path", "~> 1.3")
s.add_dependency("backports", "~> 2.6")
# The version of ruby required by this gem
View
@@ -34,9 +34,9 @@ variables:
- {name: citrus, version: "~> 2.4.1", groups: [runtime]}
- {name: temple, version: "~> 0.4.0", groups: [runtime]}
- {name: quickl, version: "~> 0.4.3", groups: [runtime]}
- - {name: awesome_print, version: "~> 1.0.2", groups: [runtime]}
- - {name: epath, version: ">= 0.2", groups: [runtime]}
+ - {name: path, version: "~> 1.3", groups: [runtime]}
- {name: backports, version: "~> 2.6", groups: [runtime]}
+ - {name: awesome_print, version: "~> 1.0.2", groups: [extra]}
- {name: tilt, version: "~> 1.3", groups: [development]}
- {name: rake, version: "~> 0.9.2", groups: [development]}
- {name: bundler, version: "~> 1.0", groups: [development]}

0 comments on commit 9db126c

Please sign in to comment.