Permalink
Browse files

Resurect backports dependency, to avoid failures under 1.8.7 and jruby.

  • Loading branch information...
1 parent 38860ad commit badc856ca719498ef3040223bedde83a0b4c67ef @blambeau committed Jun 12, 2012
Showing with 9 additions and 0 deletions.
  1. +1 −0 Gemfile
  2. +2 −0 Gemfile.lock
  3. +1 −0 lib/wlang/loader.rb
  4. +1 −0 wlang.gemspec
  5. +4 −0 wlang.noespec
View
@@ -6,6 +6,7 @@ group :runtime do
gem "quickl", "~> 0.4.3"
gem "awesome_print", "~> 1.0.2"
gem "epath", ">= 0.2"
+ gem "backports", "~> 2.6"
end
group :development do
View
@@ -2,6 +2,7 @@ GEM
remote: http://rubygems.org/
specs:
awesome_print (1.0.2)
+ backports (2.6.1)
bluecloth (2.2.0)
citrus (2.4.1)
diff-lcs (1.1.3)
@@ -25,6 +26,7 @@ PLATFORMS
DEPENDENCIES
awesome_print (~> 1.0.2)
+ backports (~> 2.6)
bluecloth (~> 2.2.0)
bundler (~> 1.0)
citrus (~> 2.4.1)
View
@@ -2,3 +2,4 @@
require "temple"
require "quickl"
require "epath"
+require 'backports' if RUBY_VERSION < "1.9"
View
@@ -134,6 +134,7 @@ Gem::Specification.new do |s|
s.add_dependency("quickl", "~> 0.4.3")
s.add_dependency("awesome_print", "~> 1.0.2")
s.add_dependency("epath", ">= 0.2")
+ s.add_dependency("backports", "~> 2.6")
# The version of ruby required by this gem
#
View
@@ -3,6 +3,9 @@ template-info:
version: 1.7.4
links:
source: https://github.com/blambeau/noe
+ manifest:
+ lib/__lower__/loader.rb:
+ safe-override: false
variables:
lower:
wlang
@@ -33,6 +36,7 @@ variables:
- {name: quickl, version: "~> 0.4.3", groups: [runtime]}
- {name: awesome_print, version: "~> 1.0.2", groups: [runtime]}
- {name: epath, version: ">= 0.2", groups: [runtime]}
+ - {name: backports, version: "~> 2.6", groups: [runtime]}
- {name: tilt, version: "~> 1.3", groups: [development]}
- {name: rake, version: "~> 0.9.2", groups: [development]}
- {name: bundler, version: "~> 1.0", groups: [development]}

0 comments on commit badc856

Please sign in to comment.