New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

drag-and-drop sometimes does not work on Windows 10 #303

Closed
az0 opened this Issue Mar 3, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@az0
Copy link
Member

az0 commented Mar 3, 2018

Symptom
On Windows 10 drag and drop does not does not work when running with administrator privileges (after answer YES to the UAC dialog: "do you want this program to..."). It does with without administrator privileges.

If explorer.exe and BleachBit are both launched with administrator privileges, then it still does not work.

Workaround

  1. Run BleachBit not as an administrator, or
  2. Run BleachBit as administrator and use the Shred options under the File menu

@az0 az0 added this to the 2.2 milestone Mar 3, 2018

@az0 az0 added the bug label Mar 3, 2018

@az0 az0 added the priority:high label Apr 2, 2018

@az0

This comment has been minimized.

Copy link
Member

az0 commented Apr 17, 2018

User Interface Privilege Isolation is a security feature added in Microsoft Windows Vista. A standard process (such as the normal Windows Explorer) cannot send messages (i.e., drag and drop) to a higher security process (i.e., BleachBit). Therefore, this is not fixable.

One workaround is to run Windows Explorer as administrator, and I will check into another work around.

@az0 az0 closed this in 253019a Apr 21, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment