New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash right after opening on Arch #107

Open
ekianjo opened this Issue Nov 14, 2018 · 4 comments

Comments

Projects
None yet
5 participants
@ekianjo

ekianjo commented Nov 14, 2018

It used to work fine until today.

Here are the messages from the Terminal:

Application.vala:155: Tootle version: 0.2.0
Application.vala:157: Kernel version: 4.19.1-arch1-1-ARCH
Notificator.vala:40: Starting: /api/v1/streaming/?stream=user
Notificator.vala:40: Starting: /api/v1/streaming/?stream=user
Notificator.vala:40: Starting: /api/v1/streaming/?stream=user
Notificator.vala:40: Starting: /api/v1/streaming/?stream=public:local
Notificator.vala:40: Starting: /api/v1/streaming/?stream=public
(com.github.bleakgrey.tootle:4942): Gtk-WARNING **: 20:14:14.174: gtk_window_set_titlebar() called on a realized window
[INFO] Watchlist.vala:23: Reloading
[INFO] Watchlist.vala:34: Watching for 0 users and 0 hashtags
[ERROR] [GLib-GIO] Settings schema 'io.elementary.desktop.wingpanel.datetime' is not installed
Trace/breakpoint trap (core dumped)

@bleakgrey

This comment has been minimized.

Owner

bleakgrey commented Nov 14, 2018

I blame Granite (elementary/granite#242)

Try downgrading or upgrading libgranite to see if it helps. There's not much I can do at the moment as Tootle heavily depends on Granite's relative date parsing functionality.

@bleakgrey bleakgrey changed the title from Mastodon crashes right after opening [0.2.0] on arch to Crash right after opening on Arch Nov 14, 2018

@goupildb

This comment has been minimized.

goupildb commented Nov 20, 2018

On 64-bit Debian Sid, libgranite has been updated on November 09, 2018.
Tootle worked in this period, then stopped working from November 14, 2018 to November 16, 2018, and yesterday, November 19, 2018 he crashed again on the same messages, without Granite being updated. Strange.

gir1.2-granite-1.0 (5.1.0-2) to 5.2.1-1
libgranite-common (5.1.0-2) to 5.2.1-1
libgranite-dev (5.1.0-2) to 5.2.1-1
libgranite5 (5.1.0-2) to 5.2.1-1

I downgrade granite to 5.1.0-+2 and then Tootle work again.

@FedericoCeratto

This comment has been minimized.

Contributor

FedericoCeratto commented Nov 24, 2018

Temporary workaround for Debian (and possibly Ubuntu) users: download the package for your architecture from https://snapshot.debian.org/package/granite/5.1.0-2/\#libgranite5_5.1.0-2 and install it with sudo dpkg -i <filename>

@decathorpe

This comment has been minimized.

decathorpe commented Dec 5, 2018

This crash is due to a silently introduced dependency of granite on wingpanel-indicator-datetime with versions 5.2 and newer.

Since I don't want to introduce nonsensical (basically the whole Pantheon DE) dependencies (and circular dependencies) to all applications using granite, I've held off updating granite on fedora and I'm working on getting this fixed upstream (port to meson: elementary/granite#240 , allowing me to easily fix this: elementary/granite#242 ).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment