Permalink
Browse files

prevent users from installing edward with incompatible tf versions

  • Loading branch information...
1 parent b643111 commit 82e534dcc416b26d1e33d077f5c538900390db50 @dustinvtran dustinvtran committed Dec 13, 2016
Showing with 5 additions and 1 deletion.
  1. +4 −0 docs/tex/getting-started.tex
  2. +1 −1 setup.py
@@ -4,6 +4,10 @@ \subsection{Getting Started}
Getting started with Edward is easy.
\subsubsection{Quick Installation}
+\textbf{Warning: TensorFlow v0.12.0rc0 and v0.12.0rc1 broke
+compatibility with Edward. Use at most
+\href{https://www.tensorflow.org/versions/r0.11/get_started/os_setup.html#download-and-setup}{TensorFlow v0.11.0} for now.}
+
To install the latest stable version, run
\begin{lstlisting}[language=Java]
View
@@ -12,7 +12,7 @@
author_email="dustin@cs.columbia.edu",
packages=['edward', 'edward.criticisms', 'edward.inferences',
'edward.models', 'edward.stats', 'edward.util'],
- install_requires=['tensorflow>=0.11.0rc0',
+ install_requires=['tensorflow>=0.11.0rc0,!=0.12.0rc0,!=0.12.0rc1',
'numpy>=1.7',
'six>=1.10.0'],
extras_require={'stan': ['pystan>=2.0.1.3'],

0 comments on commit 82e534d

Please sign in to comment.