硬件支持情况

Lvzhou edited this page Apr 19, 2018 · 16 revisions

硬件支持

即使下面没有列出的设备,blinker理论上也可以支持,在此列出的硬件为我们已经测试过的硬件。

蓝牙ble接入支持

openjumper ble串口模块 (默认波特率9600)
HM10 / HM11 (默认波特率9600)
JDY08 / JDY10 (默认波特率115200)
JDY18/JDY09 (默认波特率9600)
AT09 (默认波特率9600)
ESP32 (需配合blinker-arduino库)
树莓派3B/树莓派3B+ (需配合blinker-py或blinker-js)
香蕉派M2+/香蕉派M3 (需配合blinker-py或blinker-js)

WiFi接入支持

WiFiduino 8266 / WiFiduino 32
espduino
ESP8266/ESP32
树莓派3B/树莓派3B+
香蕉派M2+/香蕉派M3

不支持的设备

BT05 / BT05-A / HC08
以上三种蓝牙没有在广播信息中包含mac地址,导致ios有兼容问题
HC05
以上为蓝牙2.0模块,blinker目前只支持蓝牙4.x模块,且没有对2.0的支持计划

软件支持

Arduino支持库

方法1 github下载安装:

点击下载
Windows: 将下载好的blinker库解压到 我的电脑>文档>Arduino>libraries 文件夹中
Mac OS: 将下载好的blinker库解压到 文稿>Arduino>libraries 文件夹中

方法2 通过Arduino IDE库管理器安装:

通过菜单>项目>加载库>库管理器打开库管理器,搜索“blinker”,并点击安装(中国大陆可能需翻墙)

树莓派/香蕉派/Linux支持库

待更新

其他设备接入方法

WiFi设备接入
蓝牙设备接入

You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.