Skip to content
Commits on Jun 9, 2013
  1. Merge pull request #84 from minusinf/master

    committed Jun 9, 2013
    Conflicts:
    	templates/passenger-apache-centos.conf.erb
  2. Merge pull request #83 from adamcohen/master

    committed Jun 9, 2013
    change path to mod passenger.so to support puppet >= 3.9.0.beta on CentOS
  3. Merge pull request #82 from maestrodev/system-rvm-check-for-error

    committed Jun 9, 2013
    Ensure that puppet fails if system-rvm installation fails
  4. Merge pull request #81 from maestrodev/rvm-update

    committed Jun 9, 2013
    Allow updating RVM after it has been installed
  5. Merge pull request #80 from maestrodev/centos6-deps

    committed Jun 9, 2013
    Conflicts:
    	manifests/dependencies/centos.pp
  6. Merge pull request #79 from joerx/master

    committed Jun 9, 2013
    Simpler regex for installed gem version detection.
  7. Merge pull request #75 from icole:master

    committed Jun 9, 2013
    Conflicts:
    	lib/puppet/provider/rvm_system_ruby/rvm_system_ruby.rb
    	lib/puppet/type/rvm_system_ruby.rb
  8. Merge pull request #72 from avalonmediasystem/install-with-options

    committed Jun 9, 2013
    Have rvm_system_ruby accept build flags
  9. Merge pull request #70 from RewardLoop/rvm_passenger_ruby_string_gems…

    committed Jun 9, 2013
    …et_fix
    
    ruby_version should allow fully qualified strings including gemset
Commits on Jun 7, 2013
  1. @pspoerri

    Fixed variable scoping with passenger and apache

    pspoerri committed Jun 7, 2013
    Encountered variable variable referencing problems with puppet
    3.1.1. Corrected variable scoping by prepending an @ to focus on current
    scope (see http://docs.puppetlabs.com/guides/templating.html )
  2. @adamcohen

    change path to mod_passenger

    adamcohen committed Jun 7, 2013
    path to mod_passenger.so module was changed from ext/apache2/mod_passenger.so
    to libout/apache2/mod_passenger.so in version 3.9.0.beta of passenger
    (phusion/passenger@1d7ea01)
Commits on Jun 5, 2013
  1. @brettporter @carlossg
  2. @brettporter @carlossg

    only attempt to upgrade if RVM is already installed

    brettporter committed with carlossg Jun 4, 2013
    Previously, if you set a version or latest, then both the initial install and
    the upgrade would attempt to run, with the latter failing due to the notify
    resource being missing. Moved the upgrade into the check that $::rvm_version
    was set
  3. @brettporter @carlossg

    fix issues with default values

    brettporter committed with carlossg Jun 4, 2013
    Regexing undef will not match undef, only 'undef' - this resulted in
    actual_version = undef, which meant the RVM installation failed.
Commits on Jun 3, 2013
  1. @carlossg
Commits on May 30, 2013
  1. @carlossg
  2. @carlossg

    Update rvm after it has been installed if version is set

    carlossg committed May 29, 2013
    Add rvm_version fact
Commits on May 26, 2013
  1. @brettporter
Commits on May 17, 2013
  1. @joerx
Commits on Apr 23, 2013
  1. Adding support to specify autolibs mode

    Ian Cole committed Apr 22, 2013
Commits on Apr 12, 2013
  1. @mbklein
Commits on Mar 13, 2013
  1. @jefflaporte
Commits on Mar 9, 2013
  1. Merge pull request #64 from paulche/master

    committed Mar 9, 2013
    Conflicts:
    	manifests/dependencies/centos.pp
    	manifests/dependencies/oraclelinux.pp
  2. Merge pull request #60 from angusscown/master

    committed Mar 9, 2013
    passenger ruby version requirement
  3. Merge pull request #65 from sinajahan/master

    committed Mar 9, 2013
    Added Amazon to centos group dependencies
  4. Merge pull request #66 from domcleal/no-mta

    committed Mar 9, 2013
    Remove sendmail/mailx, not required
  5. Merge pull request #67 from EmpireOne/master

    committed Mar 9, 2013
    Remove uncompatible flag in gem 2.0.0
Commits on Mar 4, 2013
  1. @niclupien

    Removed uncompatible gem install flag

    niclupien committed Mar 4, 2013
    The latest version of gem removed the flag "includes-dependencies".
    It's now the default behavior in gem 2.0.0
Commits on Feb 25, 2013
  1. @domcleal
Commits on Jan 16, 2013
  1. @sinajahan

    Add Amazon to centos group

    sinajahan committed Jan 16, 2013
    so it works with AWS instances
Commits on Jan 14, 2013
  1. @Paulche

    Add compatability with puppet-stdlib

    Paulche committed Jan 13, 2013
      - ensure_packages function
Commits on Dec 14, 2012
  1. Merge pull request #61 from baphled/master

    committed Dec 13, 2012
    Resolving issues with installing rvm on Centos 5
Commits on Dec 12, 2012
  1. @baphled
Commits on Dec 10, 2012
  1. Update manifests/passenger/gem.pp

    angusscown committed Dec 11, 2012
    provide a way for puppet to ensure that the version of ruby required for passenger is a pre-requisite
Commits on Dec 8, 2012
  1. Merge pull request #59 from heffergm/rvm_alias

    committed Dec 7, 2012
    add rvm_alias puppet provider and type
Something went wrong with that request. Please try again.