Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Fix for Centos5 servers using stock ruby. #19

Closed
wants to merge 1 commit into from

2 participants

Joseph Crim Brandon Turner
Joseph Crim

Fix to allow the gemset provider to work properly on Centos 5 using site_ruby. Let me know if you would like me to tet this out on a few other platforms.

Thanks

Brandon Turner blt04 closed this pull request from a commit
Brandon Turner Remove use of String#lines
String#lines is not part of the ruby < 1.8.7 and the backport was not
working as intended.

Fixes #18.  Fixes #19.
16b2d56
Brandon Turner blt04 closed this in 16b2d56
Brandon Turner
Owner

Thanks for the pull request, but String#each doesn't work in Ruby 1.9.2. I removed all instances of String#lines. This should fix the issue, please let me know if it does not.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  lib/puppet/provider/rvm_gemset/gemset.rb
2  lib/puppet/provider/rvm_gemset/gemset.rb
View
@@ -25,7 +25,7 @@ def gemset_list
command = gemsetcommand + ['list']
output = execute(command)
- output.lines do |line|
+ output.each do |line|
if line =~ /^\s+\S+/
list << line.strip
end
Something went wrong with that request. Please try again.