Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

declare the mail gem as a dependency (Thanks Graeme Worthy!)

  • Loading branch information...
commit 5332921c010d296d76102c7342c3380c6e19d502 1 parent d95344e
Ben Mabey authored
Showing with 6 additions and 2 deletions.
  1. +2 −1  Rakefile
  2. +4 −1 email_spec.gemspec
3  Rakefile
View
@@ -22,6 +22,7 @@ begin
s.has_rdoc = true
s.extra_rdoc_files = %w(README.rdoc MIT-LICENSE.txt)
s.rubyforge_project = 'email-spec'
+ s.add_runtime_dependency "mail", "~> 2.3.0"
s.add_runtime_dependency "rspec", "~> 2.0"
end
rescue LoadError
@@ -54,7 +55,7 @@ task :clean do
FileUtils.rm_rf("examples/#{ver}_root/vendor")
end
- %w[*.sqlite3 *.log].each do |pattern|
+ %w[*.sqlite3 *.log #*#].each do |pattern|
`find . -name "#{pattern}" -delete`
end
end
5 email_spec.gemspec
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Ben Mabey", "Aaron Gibralter", "Mischa Fierer"]
- s.date = %q{2010-12-29}
+ s.date = %q{2011-05-26}
s.description = %q{Easily test email in rspec and cucumber}
s.email = %q{ben@benmabey.com}
s.extra_rdoc_files = [
@@ -172,11 +172,14 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<mail>, ["~> 2.3.0"])
s.add_runtime_dependency(%q<rspec>, ["~> 2.0"])
else
+ s.add_dependency(%q<mail>, ["~> 2.3.0"])
s.add_dependency(%q<rspec>, ["~> 2.0"])
end
else
+ s.add_dependency(%q<mail>, ["~> 2.3.0"])
s.add_dependency(%q<rspec>, ["~> 2.0"])
end
end

5 comments on commit 5332921

Paul Annesley

Trouble is, rails 3.0.7 depends on mail ~> 2.2.15, and email-spec depends on mail ~> 2.3.0.

Ben Mabey
Owner

Hmm.. since email-spec releases aren't as frequent as Rail's releases I'm not sure what to do. It seems like the best bet would be to relax the mail dep in email-spec to the lowest version of mail that is compatible with rails 3.0. Thoughts?

Paul Annesley

Yeah that sounds good.

Rails 3.0.0 depended on mail ~> 2.2.5 and the Rails 3.0.8 release candidates depends on mail ~> 2.2.19, while the upcoming Rails 3.1.0 depends on mail ~> 2.3.0.

So locking email_spec to mail ~> 2.2 sounds sensible, as long as email_spec works with those versions. I guess the riskier alternative is mail >= 2.2.5, but changes in a future mail 3.0 could easily be incompatible.

Cheers!

Ben Mabey
Owner

Thanks for doing the research Paul! I've relaxed the dependency to ~> 2.2.

Paul Annesley

Nice - thanks.

Please sign in to comment.
Something went wrong with that request. Please try again.