New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Contact Form 7 - Ajax Error #118

Closed
vzeazy opened this Issue Jul 4, 2015 · 3 comments

Comments

Projects
None yet
2 participants
@vzeazy

vzeazy commented Jul 4, 2015

Hi Ben,

Thanks for the great work with version 2 (added the hook to a Mailchimp form successfully).
However, was testing something and it looks like there might be some issue with Contact Form 7 now.

On form submission I am getting an ajax error:
"Unexpected token T"

And infinite spinning icon.

However, if I click submit a second time, the form submits.

All the best.

@bmarshall511

This comment has been minimized.

Show comment
Hide comment
@bmarshall511

bmarshall511 Jul 4, 2015

Owner

Yeah, this is a tricky one. Looks like the hidden form field doesn't get submitted with the AJAX call the first time. It's probably getting called before the code that adds the hidden input get's ran. Which is why it works the second time.

Owner

bmarshall511 commented Jul 4, 2015

Yeah, this is a tricky one. Looks like the hidden form field doesn't get submitted with the AJAX call the first time. It's probably getting called before the code that adds the hidden input get's ran. Which is why it works the second time.

@bmarshall511 bmarshall511 added the bug label Jul 4, 2015

@bmarshall511 bmarshall511 added this to the 2.0.1 Release milestone Jul 4, 2015

@bmarshall511 bmarshall511 self-assigned this Jul 4, 2015

bmarshall511 added a commit that referenced this issue Jul 4, 2015

@bmarshall511

This comment has been minimized.

Show comment
Hide comment
@bmarshall511

bmarshall511 Jul 4, 2015

Owner

Got a fix, will go out hopefully today: #119

Owner

bmarshall511 commented Jul 4, 2015

Got a fix, will go out hopefully today: #119

@vzeazy

This comment has been minimized.

Show comment
Hide comment
@vzeazy

vzeazy Jul 5, 2015

That was fast! :)
Issue is gone.

vzeazy commented Jul 5, 2015

That was fast! :)
Issue is gone.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment