Permalink
Browse files

- Updated Grizzled Scala dependency, to fix an NPE arising from a

  scala.MatchError.
- Updated all plugin dependencies.
- Upgraded to SBT 0.11.2
  • Loading branch information...
1 parent c28f2b9 commit 4c424f34c2a048e9365233c069580ac06a3c1f6b @bmc committed Mar 16, 2012
Showing with 31 additions and 45 deletions.
  1. +21 −35 build.sbt
  2. +4 −0 notes/0.8.1.markdown
  3. +1 −1 project/build.properties
  4. +5 −0 project/plugins.sbt
  5. +0 −9 project/plugins/build.sbt
View
56 build.sbt
@@ -5,7 +5,7 @@ import sqlshell.build.defs._
name := "SQLShell"
-version := "0.8.0"
+version := "0.8.1"
organization := "org.clapper"
@@ -36,15 +36,15 @@ packageBin in Compile <<=
// ---------------------------------------------------------------------------
// SBT LWM
-seq(org.clapper.sbt.lwm.LWM.lwmSettings: _*)
+seq(LWM.settings: _*)
-LWM.sourceFiles in LWM.Config <++= baseDirectory { d =>
+sources in LWM.Config <++= baseDirectory map (d =>
(d / "src" / "docs" ** "*.md").get
-}
+)
-LWM.sourceFiles in LWM.Config <++= baseDirectory { d => (d / "README.md").get ++
- (d / "LICENSE.md").get ++
- (d / "FAQ.md").get }
+sources in LWM.Config <++= baseDirectory map (d =>
+ (d / "README.md").get ++ (d / "LICENSE.md").get ++ (d / "FAQ.md").get
+)
LWM.targetDirectory in LWM.Config <<= baseDirectory(_ / "target" / "docs")
@@ -62,7 +62,7 @@ doc in Compile <<= (doc in Compile).dependsOn(
// ---------------------------------------------------------------------------
// IzPack
-seq(org.clapper.sbt.izpack.IzPack.izPackSettings: _*)
+seq(IzPack.settings: _*)
IzPack.installSourceDir in IzPack.Config <<=
baseDirectory(_ / "src" / "main" / "izpack")
@@ -89,27 +89,27 @@ IzPack.createXML in IzPack.Config <<=
// ---------------------------------------------------------------------------
// Pamflet
-seq(org.clapper.sbt.pamflet.PamfletPlugin.pamfletSettings: _*)
+//seq(org.clapper.sbt.pamflet.PamfletPlugin.pamfletSettings: _*)
-sourceDirectories in Pamflet <<= baseDirectory(bd =>
- Seq(bd / "src" / "docs" / "users-guide")
-)
+//sourceDirectories in Pamflet <<= baseDirectory(bd =>
+// Seq(bd / "src" / "docs" / "users-guide")
+//)
-logLevel in Pamflet := Level.Debug
+//logLevel in Pamflet := Level.Debug
// Force an edit of the pamflet template properties file, to substitute
// variables.
-generate in Pamflet <<= (generate in Pamflet).dependsOn(
- EditSource.edit in EditSource.Config
-)
+//generate in Pamflet <<= (generate in Pamflet).dependsOn(
+// EditSource.edit in EditSource.Config
+//)
// ---------------------------------------------------------------------------
// Edit Source settings. Only used to preprocess Pamflet stuff.
-seq(org.clapper.sbt.editsource.EditSource.editSourceSettings: _*)
+seq(EditSource.settings: _*)
-EditSource.sourceFiles in EditSource.Config <+= baseDirectory(
+sources in EditSource.Config <+= baseDirectory map (
_ / "src" / "docs" / "pamflet-template.properties"
)
@@ -128,27 +128,13 @@ EditSource.variables in EditSource.Config <+=
// Other dependendencies
libraryDependencies ++= Seq(
- "jline" % "jline" % "0.9.94",
- "org.clapper" %% "grizzled-scala" % "1.0.9",
- "org.clapper" %% "argot" % "0.3.5",
+ "jline" % "jline" % "2.6",
+ "org.clapper" %% "grizzled-scala" % "1.0.12",
+ "org.clapper" %% "argot" % "0.3.8",
"org.joda" % "joda-convert" % "1.1",
"joda-time" % "joda-time" % "2.0",
"org.scala-tools.time" %% "time" % "0.5",
"net.sf.opencsv" % "opencsv" % "2.0"
)
libraryDependencies <+= scalaVersion("org.scala-lang" % "scala-library" % _)
-
-// ---------------------------------------------------------------------------
-// Publishing criteria
-
-publishTo <<= version {(v: String) =>
- val nexus = "http://nexus.scala-tools.org/content/repositories/"
- if (v.trim.endsWith("SNAPSHOT")) Some("snapshots" at nexus + "snapshots/")
- else Some("releases" at nexus + "releases/")
-}
-
-publishMavenStyle := true
-
-credentials += Credentials(Path.userHome / "src" / "mystuff" / "scala" /
- "nexus.scala-tools.org.properties")
View
4 notes/0.8.1.markdown
@@ -0,0 +1,4 @@
+* Updated Grizzled Scala dependency, to fix an NPE arising from a
+ `scala.MatchError`.
+* Updated all plugin dependencies.
+* Upgraded to SBT 0.11.2
View
2 project/build.properties
@@ -1 +1 @@
-sbt.version=0.10.1
+sbt.version=0.11.2
View
5 project/plugins.sbt
@@ -0,0 +1,5 @@
+addSbtPlugin("org.clapper" % "sbt-lwm" % "0.3.2")
+
+addSbtPlugin("org.clapper" % "sbt-izpack" % "0.3.2")
+
+addSbtPlugin("org.clapper" % "sbt-editsource" % "0.6.2")
View
9 project/plugins/build.sbt
@@ -1,9 +0,0 @@
-libraryDependencies ++= Seq("org.clapper" %% "sbt-lwm" % "0.1.5",
- "org.clapper" %% "sbt-izpack" % "0.1.4",
- "org.clapper" %% "sbt-editsource" % "0.4.2",
- "org.clapper" %% "sbt-pamflet" % "0.1")
-
-libraryDependencies <<= (sbtVersion, scalaVersion, libraryDependencies) {
- (sbtv, scalav, deps) =>
- deps :+ "net.databinder" %% "posterous-sbt" % ("0.3.0_sbt" + sbtv)
-}

0 comments on commit 4c424f3

Please sign in to comment.