New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error "this.send is not a function" in new build intelephense #70

Open
ValeryFVV2002 opened this Issue Feb 13, 2018 · 6 comments

Comments

Projects
None yet
7 participants
@ValeryFVV2002
Copy link

ValeryFVV2002 commented Feb 13, 2018

Error on load plugin v0.8.8 (in VSCode 19.1 & 20.0)
"Request initialize failed with message: this.send is not a function"

@bmewburn

This comment has been minimized.

Copy link
Owner

bmewburn commented Feb 13, 2018

Try clearing cache and reloading

@lelinhtinh

This comment has been minimized.

Copy link

lelinhtinh commented Mar 8, 2018

I have encountered the same error. I then tried to uninstall and then reinstalled this extension, but the problem was not fixed.
I found out that, after uninstalling, it is still in the extension folder. Just delete it manually, this problem has been resolved.

  • Goto %userprofile%\.vscode\extensions.
  • Delete bmewburn.vscode-intelephense-client-x.x.x folder.
  • Re-install Intelephense extension.
@Mecit

This comment has been minimized.

Copy link

Mecit commented Apr 15, 2018

I'm having the same problem after updating to the latest release (1.22.2). Following the steps suggested by @lelinhtinh didn't work for me, either.

Edit: Never mind. After doing that and then performing a "Clear Cache and Reload", it works again.

@zqunor

This comment has been minimized.

Copy link

zqunor commented Jan 18, 2019

after i have tried, it is still output error info in OUTPUT VIEW
[Info - 4:44:58 PM] Initialising
[Error - 4:44:59 PM] Server initialization failed.
Message: Request initialize failed with message: this.send is not a function
Code: -32603

@Dev-Int

This comment has been minimized.

Copy link

Dev-Int commented Jan 29, 2019

Hello,

I have encountered the same error. I then tried to uninstall and then reinstalled this extension, but the problem was not fixed.
I found out that, after uninstalling, it is still in the extension folder. Just delete it manually, this problem has been resolved.

* Goto `%userprofile%\.vscode\extensions`.

* Delete **bmewburn.vscode-intelephense-client-x.x.x** folder.

* Re-install Intelephense extension.

I still have this error after Re-install.

I'm having the same problem after updating to the latest release (1.22.2). Following the steps suggested by @lelinhtinh didn't work for me, either.

Edit: Never mind. After doing that and then performing a "Clear Cache and Reload", it works again.

@zqunor , How did you do your "Clear Cache and Reload" ? I'm on Debian 8, and VSCode 1.30.2.

@shahrukhm2

This comment has been minimized.

Copy link

shahrukhm2 commented Feb 4, 2019

Hi,
For mac,
search using command+shift+p, intelephense: clear cache and reload, that works for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment