Permalink
Fetching contributors…
Cannot retrieve contributors at this time
61 lines (46 sloc) 1.5 KB
v1.1.1.3:
* Dependency update for HSE 1.19, HUnit 1.5 (thanks Nikolay Amiantov)
* Fix bug due to incautious naming of temporary variables (thanks Jack Fransham)
v1.1.1.2:
* Dependency update for base 4.9, QuickCheck 2.9
v1.1.1.1:
* Dependency update for HSE 1.17, transformers 0.5
* Trim tested-with, I no longer have a working copy of old GHCs
v1.1.1:
* Fix some bugs in qualified operator handling
v1.1:
* Drop support for GHC 7.0 and 7.2 (actually already lost with HSE 1.16)
* Add support for GHC 7.10.1
* Expose the string -> string transformation as a library (thanks Taylor Fausak)
* Add --stdin flag to enable reading from stdin (thanks Martin Zeller)
* Support some Unicode operators
* Dependency update for QuickCheck 2.9
v1.0.4.8:
* Dependency update for HSE 1.16
* Fixing support for transformers 0.4
v1.0.4.7:
* Dependency update for HSE 1.15 and transformers 0.4
v1.0.4.6:
* Dependency update for GHC 7.8
* Comment out tests that never worked
v1.0.4.5:
* Fix using show when I meant prettyprint
* Fix testsuite dependencies
* Replace mtl dep with transformers
* Broaden HSE dep version range
v1.0.4.4:
* Replace custom parser with HSE parser, fixing many bugs
* Dependency update for GHC 7.6
* Use cabal's test-suite stuff
v1.0.4.3:
* Dependency update for GHC 7.4
v1.0.4.2: (never released on Hackage)
* Dependency update for GHC 7.2
v1.0.4.1:
* Metadata fix
v1.0.4:
* Modernise pragma/extension usage
* Update for mtl-2
* Squash some warnings
v1.0.3:
* Last version released before I took maintainership