Meteor: Error with Meteor 0.6.0 #161

Closed
sbking opened this Issue Apr 5, 2013 · 0 comments

Comments

Projects
None yet
2 participants

sbking commented Apr 5, 2013

I'm getting this error when I start up mrt on meteor 0.6.0:

Errors prevented startup:
Exception while bundling application:
ReferenceError: require is not defined
    at /Users/Stephen/Projects/project/.meteor/meteorite/packages/blade/package.js:42:10
    at _.extend.add_file (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/bundler.js:210:7)
    at self.api.add_files (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/bundler.js:126:16)
    at Array.forEach (native)
    at Function._.each._.forEach (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/dev_bundle/lib/node_modules/underscore/underscore.js:79:11)
    at self.api.add_files (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/bundler.js:125:11)
    at Array.forEach (native)
    at Function._.each._.forEach (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/dev_bundle/lib/node_modules/underscore/underscore.js:79:11)
    at Object.self.api.add_files (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/bundler.js:124:9)
    at _.extend.init_from_app_dir [as on_use_handler] (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/packages.js:239:11)
    at _.extend.use (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/bundler.js:445:11)
    at Object.exports.bundle (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/bundler.js:854:12)
    at /Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/run.js:694:26
    at exports.inFiber (/Users/Stephen/.meteorite/meteors/meteor/meteor/cab491f3650fffc85661bca6b3cecf583410e05d/tools/fiber-helpers.js:24:12)
Your application is crashing. Waiting for file change.

I can look into the issue a bit to see if it's an easy fix. I think it has something to do with the changes for Npm modules in 0.6.0.

bminer was assigned Apr 8, 2013

bminer closed this in 1ea24e7 Apr 8, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment