Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

note that Sinatra::Default is obsolete in CHANGES

  • Loading branch information...
commit 79a99939167b039bc740d693eb25a4ed09b37b52 1 parent 45ba561
@rtomayko rtomayko authored
Showing with 16 additions and 7 deletions.
  1. +16 −7 CHANGES
View
23 CHANGES
@@ -50,17 +50,24 @@
* The X-Cascade response header is set to 'pass' when no matching route
is found or all routes pass. (Josh Peek)
- * The `sinatra/test` library is obsolete. This includes the
- `Sinatra::Test` module, the `Sinatra::TestHarness` class,
- and the `get_it`, `post_it`, `put_it`, `delete_it`, and `head_it`
- helper methods. The
+The following Sinatra features have been obsoleted (removed entirely) in
+the 1.0 release:
+
+ * The `sinatra/test` library is obsolete. This includes the `Sinatra::Test`
+ module, the `Sinatra::TestHarness` class, and the `get_it`, `post_it`,
+ `put_it`, `delete_it`, and `head_it` helper methods. The
[`Rack::Test` library](http://gitrdoc.com/brynary/rack-test) should
be used instead.
* Test framework specific libraries (`sinatra/test/spec`,
- `sinatra/test/bacon`,`sinatra/test/rspec`, etc.) are obsolete.
- See http://www.sinatrarb.com/testing.html for instructions on
- setting up a testing environment under each of these frameworks.
+ `sinatra/test/bacon`,`sinatra/test/rspec`, etc.) are obsolete. See
+ http://www.sinatrarb.com/testing.html for instructions on setting up a
+ testing environment under each of these frameworks.
+
+ * `Sinatra::Default` is obsolete; use `Sinatra::Base` instead.
+ `Sinatra::Base` acts more like `Sinatra::Default` in development mode.
+ For example, static file serving and sexy development error pages are
+ enabled by default.
* Auto-requiring template libraries in the `erb`, `builder`, `haml`,
and `sass` methods is obsolete due to thread-safety issues. You must
@@ -75,6 +82,8 @@
* The 'media_type' helper method is obsolete. Use 'mime_type' instead.
+ * The 'mime' main and class method is obsolete. Use 'mime_type' instead.
+
* The request-level `send_data` method is no longer supported.
* The `Sinatra::Event` and `Sinatra::EventContext` classes are no longer
Please sign in to comment.
Something went wrong with that request. Please try again.