New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support PHP 7.1.x and PHP 7.2.x #7

Open
bobbingwide opened this Issue Feb 6, 2017 · 2 comments

Comments

Projects
None yet
1 participant
@bobbingwide
Copy link
Owner

bobbingwide commented Feb 6, 2017

PHP 7.1 is available. The code doesn't yet support it.
The following message is evidence.

Fatal error: Cannot use $this as parameter in /home/bwdesign/public_html/wp-content/plugins/oik-types/oik-types.php on line 384

Simple solution: Rename $this to $thus

See https://wiki.php.net/rfc/this_var

@bobbingwide bobbingwide self-assigned this Feb 6, 2017

bobbingwide added a commit that referenced this issue Feb 6, 2017

@bobbingwide

This comment has been minimized.

Copy link
Owner Author

bobbingwide commented Feb 2, 2018

PHP 7.2 is also available.
Note: We haven't closed this issue since there are no PHPUnit tests yet.

@bobbingwide bobbingwide changed the title Support PHP 7.1.x Support PHP 7.1.x and PHP 7.2.x Feb 2, 2018

@bobbingwide

This comment has been minimized.

Copy link
Owner Author

bobbingwide commented Jan 18, 2019

The version that supports PHP 7.2 was mistakenly labeled 2.0.0-alpha-20181019 but released as 2.0.0-20181019. Need to correct and re-zip.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment