Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 87 lines (67 sloc) 3.245 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
Revision history for JSON-Any

        * Update JSON::XS tests to deal with inconsistent white space generation between
          releases (t0m)

1.21 2009-07-03
        * Update JSON::XS boolean support; it provides true/false methods (semifor)
        * Added a workaround for handlers that fail to decode bare true/false values (semifor)

1.20 2009-07-02
        * Re-work things so that deprecated modules just warn but aren't actually excluded (perigrin)
        * Improve the warnings when things go awry (semifor)

1.19 2009-01-15
        * Make JSON::Syck optional and deprecated. (perigrin)
        * Added tests for string escapes. (semifor)

1.18 2008-11-12
        * Removed JSON::PC support as it's been removed from CPAN (perigrin)

1.17 2008-07-05
        * Added documentation indicating that allow_blessed works for most useful
          cases (Robin Berjon)
        * Added support for obtaining the underlying representations for
          true/false in JSON.

1.16 2008-02-13
        * JSON::Any now compatible with both versions of JSON::XS (Simon Wistow)
        * Document that calling 'use JSON::Any ();' is a bad idea
        * Make JSON.pm required unless a supported JSON package is already installed

1.15 2008-01-02
        * Update the config params for JSON and JSON/XS configuration
        * Update JSON handler to always pass in the -support_by_pp option
          if you don't want support_by_pp then don't use JSON.pm ...
        *** THIS VERSION WILL ONLY WORK ON 2.0+ VERSIONS OF THESE MODULES ***

1.14 2007-12-20
        * Fix for the new JSON/JSON::XS 2.0
        *** THIS VERSION WILL ONLY WORK ON 2.0+ VERSIONS OF THESE MODULES ***

1.13 2007-11-06
        * Fix 10_unicode.t to skip_all if no supported unicode backend is found
         (reported by Andreas Kˆnig)

1.12 2007-10-22
        * Fix issue with 05-JSON-Syck.t so we can pass our tests again

1.11 17 Oct 2007
        * fix issue with JSON::Syck when using Object API as reported by Miyagawa

1.10 12 Oct 2007
        * fix issues from http://rt.cpan.org/Public/Bug/Display.html?id=29917

1.09 10 Oct 2007
        * also test for is_utf8() - nothingmuch
        * improve unicode test - nothingmuch
        * add utf8 support for JSON::{Converter,Parser} - nothingmuch
        * Add a test for unicode strings - nothingmuch

1.08 18 May 2007
        * Fix Packaging
        * Fix JSON.pm backend tests
        * fix issues with JSON::XS being pedantic about how it's methods/functions are called
        * added a carp requirement

1.07 ???
        * changed Makefile.PL to Module::Install
        * helps if I test 04-ENV.t against the code it was designed for
        * skip all 04-ENV.t until I get it working
        * fixing tests
        * change to skip_all based skippage
        * add example directory
        * pod updates

1.06 ???
        * cleaned up t/04-ENV.t to not require JSON::XS anymore
        * fixed split on uninitalized value error
        * cleaned up JSON-XS tests a bit
        * added 04-ENV.t to MANIFEST

... History is Elusive ...

1.00 Fri Mar 23 10:24:50 EDT 2007
        * Initial Release
        * Currently only supports objToJson and jsonToObj
Something went wrong with that request. Please try again.