Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incompatible versions for gem 'Sinatra' #112

Closed
henry74 opened this issue May 13, 2013 · 3 comments
Closed

Incompatible versions for gem 'Sinatra' #112

henry74 opened this issue May 13, 2013 · 3 comments
Labels

Comments

@henry74
Copy link

@henry74 henry74 commented May 13, 2013

When trying to install genghis with Padrino 0.11.1 I get the following dependency error:

Bundler could not find compatible versions for gem "sinatra":
In Gemfile:
genghisapp (>= 0) ruby depends on
sinatra (~> 1.3.3) ruby

padrino (= 0.11.1) ruby depends on
  sinatra (1.4.2)

Any ideas why 1.4.2 wouldn't be accepted for genghisapp?

Thanks,
Henry

@bobthecow
Copy link
Owner

@bobthecow bobthecow commented May 13, 2013

Because it doesn't currently work with 1.4.2 :)

Some things changed in Sinatra 1.4 that I haven't had time to update for yet.

@henry74
Copy link
Author

@henry74 henry74 commented May 14, 2013

If you can point me at the right files, I'll take a look and see if I can make the updates in a fork.

@bobthecow
Copy link
Owner

@bobthecow bobthecow commented Jun 25, 2013

This has been fixed in develop and will be in the next release.

@bobthecow bobthecow closed this in 121f24b Jun 25, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.