New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to delete server from list #145

Closed
CalvertYang opened this Issue Nov 2, 2013 · 9 comments

Comments

Projects
None yet
3 participants
@CalvertYang

I got 404 error when remove server from list, is there any other way can remove server from list?

My genghis is Version 2.3.8 and starting by execute command genghisapp

2013-11-03 12 51 43

@bobthecow

This comment has been minimized.

Show comment
Hide comment
@bobthecow

bobthecow Nov 2, 2013

Owner

That's weird. It looks like it's trying to delete /servers, not /servers/$serverid (but it is a bit hard to tell from your screenshot). Can you confirm for me?

Owner

bobthecow commented Nov 2, 2013

That's weird. It looks like it's trying to delete /servers, not /servers/$serverid (but it is a bit hard to tell from your screenshot). Can you confirm for me?

@CalvertYang

This comment has been minimized.

Show comment
Hide comment
@CalvertYang

CalvertYang Nov 3, 2013

I tried two situation as follow:

  1. Add server: user@localhost:27017/test
    Result: Remove from list successful

    2013-11-03 10 04 21

  2. Add server: user:pass@localhost:27017/test
    Result: Cannot remove from list

    2013-11-03 9 58 11

If i add a server that has password, it cannot remove from list.

Hope these information can help you to find out the issue, feel free to tell me if you need any further information.

I tried two situation as follow:

  1. Add server: user@localhost:27017/test
    Result: Remove from list successful

    2013-11-03 10 04 21

  2. Add server: user:pass@localhost:27017/test
    Result: Cannot remove from list

    2013-11-03 9 58 11

If i add a server that has password, it cannot remove from list.

Hope these information can help you to find out the issue, feel free to tell me if you need any further information.

@bobthecow

This comment has been minimized.

Show comment
Hide comment
@bobthecow

bobthecow Nov 3, 2013

Owner

That is quite strange. Both are deletable for me.

What is the output of ruby --version and genghisapp --version for you?

Owner

bobthecow commented Nov 3, 2013

That is quite strange. Both are deletable for me.

What is the output of ruby --version and genghisapp --version for you?

@CalvertYang

This comment has been minimized.

Show comment
Hide comment
@CalvertYang

CalvertYang Nov 3, 2013

ruby --version

ruby 1.9.3p448 (2013-06-27 revision 41675)

genghisapp --version

'genghisapp' 2.3.8
rack 1.2
sinatra 1.4.4
vegas 0.1.11

BTW, my ruby is installed by rvm.

ruby --version

ruby 1.9.3p448 (2013-06-27 revision 41675)

genghisapp --version

'genghisapp' 2.3.8
rack 1.2
sinatra 1.4.4
vegas 0.1.11

BTW, my ruby is installed by rvm.

@bobthecow

This comment has been minimized.

Show comment
Hide comment
@bobthecow

bobthecow Nov 3, 2013

Owner

When you run genghisapp is it running your rvm version of ruby?

Owner

bobthecow commented Nov 3, 2013

When you run genghisapp is it running your rvm version of ruby?

@CalvertYang

This comment has been minimized.

Show comment
Hide comment
@CalvertYang

CalvertYang Nov 3, 2013

Oops, I found the reason that why I cannot delete the server from list.

The browser cache let me misunderstanding the server still on the list, but it has been deleted.

Thanks for your help.

Oops, I found the reason that why I cannot delete the server from list.

The browser cache let me misunderstanding the server still on the list, but it has been deleted.

Thanks for your help.

@CalvertYang CalvertYang closed this Nov 3, 2013

@bobthecow

This comment has been minimized.

Show comment
Hide comment
@bobthecow

bobthecow Nov 3, 2013

Owner

Cache is also a problem, as Genghis should be preventing the browser from caching anything :)

Owner

bobthecow commented Nov 3, 2013

Cache is also a problem, as Genghis should be preventing the browser from caching anything :)

@CalvertYang

This comment has been minimized.

Show comment
Hide comment
@CalvertYang

CalvertYang Nov 3, 2013

That's really strange. I found that after I add a server, and than clear the browser cookie, the server is disappear from the list.

I think the server doesn't added from the beginning, but I'm sure the connection information is correct and the remote mongodb is running.

That's really strange. I found that after I add a server, and than clear the browser cookie, the server is disappear from the list.

I think the server doesn't added from the beginning, but I'm sure the connection information is correct and the remote mongodb is running.

@JoeyHoutenbos

This comment has been minimized.

Show comment
Hide comment
@JoeyHoutenbos

JoeyHoutenbos May 1, 2015

I had the same problem. The caching was indeed the problem.
After deleting the cookie the servers where removed...

PS: I am using the PHP version

I had the same problem. The caching was indeed the problem.
After deleting the cookie the servers where removed...

PS: I am using the PHP version

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment