New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Genghis stuck #46

Closed
romanesko opened this Issue Oct 23, 2012 · 3 comments

Comments

Projects
None yet
2 participants
@romanesko

It got stuck (

https://www.evernote.com/shard/s16/sh/f350f0cd-50a8-40d8-8f5f-494176d4afba/9ffcd6cee578648535c7fc4841aa9aef

I've also tried to update thr version, but gem install genghisapp installs the old version
The version downloaded from the site falls with the following error:

/Users/macmini/Downloads/genghis-2.1.2/genghis.rb:13:in `require': no such file to load -- mongo (LoadError)
    from /Users/macmini/Downloads/genghis-2.1.2/genghis.rb:13
@bobthecow

This comment has been minimized.

Show comment
Hide comment
@bobthecow

bobthecow Oct 23, 2012

Owner

I'm not sure why it's stuck, but I'd guess it's trying to connect to a server that's timing out. Try clearing your cookies and seeing if it loads.

gem install genghisapp should be installing v2.1.2 (that's the version listed on rubygems.org)... I don't know what's happening there.

If you're running the downloaded version under Ruby 1.8.x, you might need rubygems for it to work. Try this:

ruby -rubygems genghis.rb
Owner

bobthecow commented Oct 23, 2012

I'm not sure why it's stuck, but I'd guess it's trying to connect to a server that's timing out. Try clearing your cookies and seeing if it loads.

gem install genghisapp should be installing v2.1.2 (that's the version listed on rubygems.org)... I don't know what's happening there.

If you're running the downloaded version under Ruby 1.8.x, you might need rubygems for it to work. Try this:

ruby -rubygems genghis.rb
@romanesko

This comment has been minimized.

Show comment
Hide comment
@romanesko

romanesko Oct 24, 2012

It stucks here:

GET http://0.0.0.0:5678/servers 500 (Internal Server Error)

{"status":500,"error":"Database command 'listDatabases' failed: (errmsg: 'need to login'; ok: '0.0')."}

It stucks here:

GET http://0.0.0.0:5678/servers 500 (Internal Server Error)

{"status":500,"error":"Database command 'listDatabases' failed: (errmsg: 'need to login'; ok: '0.0')."}

@bobthecow

This comment has been minimized.

Show comment
Hide comment
@bobthecow

bobthecow Oct 27, 2012

Owner

Ahh. Your server requires authentication? There's an outstanding bug with that (#16) in some cases, I expect to have it fixed for the next point release.

Closing as a duplicate.

Owner

bobthecow commented Oct 27, 2012

Ahh. Your server requires authentication? There's an outstanding bug with that (#16) in some cases, I expect to have it fixed for the next point release.

Closing as a duplicate.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment