Permalink
Browse files

let meta die loudly if a theme can't be loaded

  • Loading branch information...
1 parent 0aa8308 commit 2b8c7db2bf572b391766d33f9af37e6abe3e46c8 @book committed May 9, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1 script/meta
View
@@ -36,7 +36,7 @@ my $module = "Acme::MetaSyntactic::$theme";
# load the remote theme if needed
if ( $conf{remote} || $conf{check} || $conf{sources}) {
- eval "require $module;";
+ eval "require $module; 1;" or die $@;
die "Theme '$theme' is not updatable!\n"
unless $module->has_remotelist();
}

0 comments on commit 2b8c7db

Please sign in to comment.