Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

clojure.lang.Compiler$CompilerException: clojure.lang.ArityException: Wrong number of args (4) passed to: StringReader, compiling:(abnf.clj:186:28) #210

Closed
alandipert opened this issue May 29, 2015 · 2 comments
Labels
Bug
Milestone

Comments

@alandipert
Copy link
Contributor

@alandipert alandipert commented May 29, 2015

boot.user=> (set-env! :dependencies '[[org.clojure/clojure "1.6.0"] [org.clojure/clojurescript "0.0-3211"] [instaparse "1.4.0"]])
nil
boot.user=> (require 'instaparse.core)

clojure.lang.Compiler$CompilerException: clojure.lang.ArityException: Wrong number of args (4) passed to: StringReader, compiling:(abnf.clj:186:28)
            clojure.lang.ArityException: Wrong number of args (4) passed to: StringReader

boot.core/add-dependencies! was attempting to strip Clojure dependencies from dependency vectors before resolving dependencies.

This influenced the version of the dependencies selected in a way that diverged from Lein/aether, and the end result was that two different Clojure versions were on the classpath at the same time.

This caused instaparse's Clojure version sniffing hack in instaparse.cfg to think it was on 1.7 when it was actually on 1.6.

@alandipert alandipert added the Bug label May 29, 2015
@alandipert alandipert added this to the 2.1.1 milestone May 29, 2015
@borkdude
Copy link

@borkdude borkdude commented May 29, 2015

Thanks for fixing!

@martinklepsch
Copy link
Member

@martinklepsch martinklepsch commented May 31, 2015

Great you figured it out! 👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.