New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

C Plugins: Not working on Cygwin #749

Open
boothj5 opened this Issue Feb 28, 2016 · 1 comment

Comments

Projects
None yet
1 participant
@boothj5
Owner

boothj5 commented Feb 28, 2016

On Cygwin, C plugins cannot call the prof_* functions as they are all assigned NULL, the assignment in c_api_init seems to have no effect.

This is probably due to creation and linking of shared libraries on Cygwin needing more platform specific options in the build.

@boothj5 boothj5 added this to the 0.5.0 milestone Feb 28, 2016

@boothj5 boothj5 modified the milestones: 0.5.1, 0.5.0 Jun 16, 2016

@boothj5

This comment has been minimized.

Show comment
Hide comment
@boothj5

boothj5 Jun 16, 2016

Owner

Moved to 0.5.1 release, giving up on this one for 0.5.0 since I still haven't found a solution and it's holding up the release.

Will list it as a known issue for 0.5.0 on the website.

Owner

boothj5 commented Jun 16, 2016

Moved to 0.5.1 release, giving up on this one for 0.5.0 since I still haven't found a solution and it's holding up the release.

Will list it as a known issue for 0.5.0 on the website.

@boothj5 boothj5 modified the milestones: 0.6.0, 0.5.1 Jan 16, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment