Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

1.1-maint: python3.4 #4343

Closed
ThomasWaldmann opened this issue Feb 10, 2019 · 3 comments

Comments

Projects
None yet
1 participant
@ThomasWaldmann
Copy link
Member

commented Feb 10, 2019

we support python 3.4 in borg 1.1.x.

but python 3.4 support is ending 2019-03 and also pip is dropping 3.4 support for pip > 19.1, pytest >= 5.0 is also dropping 3.4.

so, we'll likely have to add pip <= 19.1, pytest < 5.0 to our requirements.
or check the vagrant VMs whether we can use python >= 3.5 on some where currently 3.4 is used.

@ThomasWaldmann ThomasWaldmann added this to the 1.1.x milestone Feb 10, 2019

@ThomasWaldmann

This comment has been minimized.

Copy link
Member Author

commented Feb 10, 2019

VMs:

  • netbsd64
  • openindiana64

@ThomasWaldmann ThomasWaldmann modified the milestones: 1.1.x, 1.1.10 Feb 11, 2019

@ThomasWaldmann ThomasWaldmann changed the title 1.1-maint: pip and python3.4 1.1-maint: python3.4 Feb 11, 2019

@ThomasWaldmann

This comment has been minimized.

Copy link
Member Author

commented Mar 8, 2019

master branch is currently on py35+ (it already was on py36+, but i reverted that again to py35+ due to debian stable still having py35). most future development will happen there.

for 1.1-maint (and this ticket is only about 1.1-maint), it wouldn't be nice to remove 3.4 support as we have supported this for all 1.1.x releases yet. major changes in a patch release are a no-no.

so i guess i'll try pinning the test environment to tool versions that still work with 3.4.

@ThomasWaldmann ThomasWaldmann self-assigned this Mar 24, 2019

ThomasWaldmann added a commit to ThomasWaldmann/borg that referenced this issue Mar 24, 2019

lock travis-ci test env to py 3.4 compatible versions, fixes borgback…
…up#4343

maybe slightly newer will also work, e.g. pip < 19.2, pytest < 5.0.

ThomasWaldmann added a commit that referenced this issue Mar 24, 2019

Merge pull request #4472 from ThomasWaldmann/freeze-test-env
lock travis-ci test env to py 3.4 compatible versions, fixes #4343
@ThomasWaldmann

This comment has been minimized.

Copy link
Member Author

commented Mar 24, 2019

fixed by #4472.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.