Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Clean up and bump version.

  • Loading branch information...
commit c2b72d2a9239fcaefbe4c281a52adc303c82bc5d 1 parent 1bc4393
@boronine authored
Showing with 2 additions and 15 deletions.
  1. BIN  .pypyenv.py.swp
  2. +0 −1  README.markdown
  3. +2 −14 pypyenv.py
View
BIN  .pypyenv.py.swp
Binary file not shown
View
1  README.markdown
@@ -14,7 +14,6 @@ This script supports Linux and (experimentally) OS X.
source myenv/bin/activate
easy_install pypyenv
pypyenv install # Tries to install PyPy with JIT
- pypyenv --nojit install # Forces non-JIT installation
pypyenv uninstall # Uninstalls PyPy from virtualenv
pypyenv will create a `pypy` executable in your virtualenv's `bin` folder,
View
16 pypyenv.py
@@ -7,7 +7,7 @@
import getopt
import platform
-__version__ = "0.1.1"
+__version__ = "0.1.2"
base = sys.prefix
srcdir = "src"
@@ -83,30 +83,18 @@ def confirm_deletion(tree):
return raw_input("Delete ENV/%s? [y/N] " % tree) in yes
help_message = """ pypyenv install - installs PyPy in this virtualenv
- pypyenv uninstall - uninstalls PyPy from this virtualenv
- --nojit - Install non-JIT version."""
+ pypyenv uninstall - uninstalls PyPy from this virtualenv"""
def main():
if version != "2.7":
if not raw_input("PyPy implements Python 2.7, you are using a " \
"different version, continue? [y/N] ") in yes:
sys.exit(1)
- try:
- opts, args = getopt.getopt(sys.argv[1:], "", ["nojit"])
- except getopt.GetoptError:
- print help_message
- sys.exit(2)
if len(args) != 1:
print help_message
sys.exit(2)
- nojit = False
- for o, a in opts:
- if o == "--nojit":
- nojit = True
- jit = not nojit
-
osx = platform.system() == "Darwin"
win = platform.system() == "Windows"
linux = not osx and not win
Please sign in to comment.
Something went wrong with that request. Please try again.