Permalink
Browse files

Update to Rails 3.2.0

  • Loading branch information...
1 parent b067291 commit 92a433329744bc8e44d4d9e5b5a56c2ba4dd8d9d @bcardarella bcardarella committed Jan 20, 2012
Showing with 96 additions and 96 deletions.
  1. +5 −5 Gemfile
  2. +88 −91 Gemfile.lock
  3. +3 −0 config/application.rb
View
10 Gemfile
@@ -1,10 +1,10 @@
source :rubygems
-gem 'rails', '~> 3.1.1'
+gem 'rails', '~> 3.2.0'
gem 'jquery-rails', '~> 1.0.0'
gem 'high_voltage', '~> 0.9'
-gem 'kaminari', '~> 0.12.4'
+gem 'kaminari', '~> 0.13.0'
gem 'simple_form', '~> 1.4.0'
gem 'friendly_id', '~> 3.3.0.1'
gem 'stamp', '~> 0.1.0'
@@ -14,14 +14,14 @@ gem 'client_side_validations', '~> 3.1.0'
# and rake tasks without having to type RAILS_ENV=test.
group :development, :test do
gem 'sqlite3'
- gem 'rspec-rails', '~> 2.6.0'
+ gem 'rspec-rails', '~> 2.8.1'
gem 'ruby-debug19', '~> 0.11.6', :require => 'ruby-debug'
gem 'memcache-client'
end
group :assets do
- gem 'sass-rails', '~> 3.1.0'
- gem 'coffee-rails', '~> 3.1.0'
+ gem 'sass-rails', '~> 3.2.0'
+ gem 'coffee-rails', '~> 3.2.0'
gem 'uglifier'
gem 'compass', '~> 0.12.alpha'
end
View
@@ -1,61 +1,60 @@
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.1)
- actionpack (= 3.1.1)
- mail (~> 2.3.0)
- actionpack (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
+ actionmailer (3.2.0)
+ actionpack (= 3.2.0)
+ mail (~> 2.4.0)
+ actionpack (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- i18n (~> 0.6)
- rack (~> 1.3.2)
+ journey (~> 1.0.0)
+ rack (~> 1.4.0)
rack-cache (~> 1.1)
- rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.0.2)
- activemodel (3.1.1)
- activesupport (= 3.1.1)
+ sprockets (~> 2.1.2)
+ activemodel (3.2.0)
+ activesupport (= 3.2.0)
builder (~> 3.0.0)
- i18n (~> 0.6)
- activerecord (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
- arel (~> 2.2.1)
+ activerecord (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
+ arel (~> 3.0.0)
tzinfo (~> 0.3.29)
- activeresource (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
- activesupport (3.1.1)
+ activeresource (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
+ activesupport (3.2.0)
+ i18n (~> 0.6)
multi_json (~> 1.0)
addressable (2.2.6)
archive-tar-minitar (0.5.2)
- arel (2.2.1)
- babosa (0.3.5)
+ arel (3.0.0)
+ babosa (0.3.6)
bourne (1.0)
mocha (= 0.9.8)
builder (3.0.0)
- capybara (1.1.1)
+ capybara (1.1.2)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- childprocess (0.2.2)
+ childprocess (0.3.0)
ffi (~> 1.0.6)
chunky_png (1.2.5)
- client_side_validations (3.1.3)
- coffee-rails (3.1.1)
+ client_side_validations (3.1.4)
+ coffee-rails (3.2.1)
coffee-script (>= 2.2.0)
- railties (~> 3.1.0)
+ railties (~> 3.2.0.beta)
coffee-script (2.2.0)
coffee-script-source
execjs
- coffee-script-source (1.1.2)
- columnize (0.3.4)
- compass (0.12.alpha.0)
+ coffee-script-source (1.2.0)
+ columnize (0.3.6)
+ compass (0.12.alpha.4)
chunky_png (~> 1.2)
fssm (>= 0.2.7)
sass (~> 3.1)
@@ -66,85 +65,85 @@ GEM
mail (~> 2.2)
rspec (~> 2.0)
erubis (2.7.0)
- execjs (1.2.9)
+ execjs (1.3.0)
multi_json (~> 1.0)
factory_girl (1.3.3)
factory_girl_rails (1.0.1)
factory_girl (~> 1.3)
railties (>= 3.0.0)
- ffi (1.0.9)
+ ffi (1.0.11)
friendly_id (3.3.0.1)
babosa (~> 0.3.0)
- fssm (0.2.7)
+ fssm (0.2.8.1)
high_voltage (0.9.4)
hike (1.2.1)
i18n (0.6.0)
- jquery-rails (1.0.16)
+ journey (1.0.0)
+ jquery-rails (1.0.19)
railties (~> 3.0)
thor (~> 0.14)
- json (1.6.1)
- json_pure (1.6.1)
- kaminari (0.12.4)
- rails (>= 3.0.0)
+ json (1.6.5)
+ kaminari (0.13.0)
+ actionpack (>= 3.0.0)
+ activesupport (>= 3.0.0)
+ railties (>= 3.0.0)
launchy (2.0.5)
addressable (~> 2.2.6)
linecache19 (0.5.12)
ruby_core_source (>= 0.1.4)
- mail (2.3.0)
+ mail (2.4.1)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
memcache-client (1.8.5)
mime-types (1.17.2)
mocha (0.9.8)
rake
- multi_json (1.0.3)
+ multi_json (1.0.4)
nokogiri (1.5.0)
- pg (0.11.0)
+ pg (0.12.2)
polyglot (0.3.3)
- rack (1.3.5)
+ rack (1.4.0)
rack-cache (1.1)
rack (>= 0.4)
- rack-mount (0.8.3)
- rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.1)
- actionmailer (= 3.1.1)
- actionpack (= 3.1.1)
- activerecord (= 3.1.1)
- activeresource (= 3.1.1)
- activesupport (= 3.1.1)
+ rails (3.2.0)
+ actionmailer (= 3.2.0)
+ actionpack (= 3.2.0)
+ activerecord (= 3.2.0)
+ activeresource (= 3.2.0)
+ activesupport (= 3.2.0)
bundler (~> 1.0)
- railties (= 3.1.1)
- railties (3.1.1)
- actionpack (= 3.1.1)
- activesupport (= 3.1.1)
+ railties (= 3.2.0)
+ railties (3.2.0)
+ actionpack (= 3.2.0)
+ activesupport (= 3.2.0)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
rake (0.9.2.2)
- rdoc (3.11)
+ rdoc (3.12)
json (~> 1.4)
redis (2.2.2)
redis-store (1.0.0.1)
redis (~> 2.2.1)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
+ rspec (2.8.0)
+ rspec-core (~> 2.8.0)
+ rspec-expectations (~> 2.8.0)
+ rspec-mocks (~> 2.8.0)
+ rspec-core (2.8.0)
+ rspec-expectations (2.8.0)
diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
- rspec-rails (2.6.1)
- actionpack (~> 3.0)
- activesupport (~> 3.0)
- railties (~> 3.0)
- rspec (~> 2.6.0)
+ rspec-mocks (2.8.0)
+ rspec-rails (2.8.1)
+ actionpack (>= 3.0)
+ activesupport (>= 3.0)
+ railties (>= 3.0)
+ rspec (~> 2.8.0)
ruby-debug-base19 (0.11.25)
columnize (>= 0.3.1)
linecache19 (>= 0.5.11)
@@ -155,43 +154,41 @@ GEM
ruby-debug-base19 (>= 0.11.19)
ruby_core_source (0.1.5)
archive-tar-minitar (>= 0.5.2)
- rubyzip (0.9.4)
- sass (3.1.10)
- sass-rails (3.1.4)
- actionpack (~> 3.1.0)
- railties (~> 3.1.0)
- sass (>= 3.1.4)
- sprockets (~> 2.0.0)
- tilt (~> 1.3.2)
- selenium-webdriver (2.10.0)
- childprocess (>= 0.2.1)
- ffi (= 1.0.9)
- json_pure
+ rubyzip (0.9.5)
+ sass (3.1.12)
+ sass-rails (3.2.3)
+ railties (~> 3.2.0.beta)
+ sass (>= 3.1.10)
+ tilt (~> 1.3)
+ selenium-webdriver (2.17.0)
+ childprocess (>= 0.2.5)
+ ffi (~> 1.0.9)
+ multi_json (~> 1.0.4)
rubyzip
simple-rss (1.2.3)
simple_form (1.4.2)
actionpack (~> 3.0)
activemodel (~> 3.0)
- sprockets (2.0.3)
+ sprockets (2.1.2)
hike (~> 1.2)
rack (~> 1.0)
- tilt (!= 1.3.0, ~> 1.1)
- sqlite3 (1.3.4)
+ tilt (~> 1.1, != 1.3.0)
+ sqlite3 (1.3.5)
stamp (0.1.6)
thor (0.14.6)
tilt (1.3.3)
timecop (0.3.5)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.30)
- uglifier (1.0.4)
+ tzinfo (0.3.31)
+ uglifier (1.2.2)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
valid_attribute (1.2.0)
vcr (1.10.3)
webmock (1.6.4)
- addressable (> 2.2.5, ~> 2.2)
+ addressable (~> 2.2, > 2.2.5)
crack (>= 0.1.7)
xpath (0.1.4)
nokogiri (~> 1.3)
@@ -203,23 +200,23 @@ DEPENDENCIES
bourne (~> 1.0)
capybara (~> 1.1.0)
client_side_validations (~> 3.1.0)
- coffee-rails (~> 3.1.0)
+ coffee-rails (~> 3.2.0)
compass (~> 0.12.alpha)
database_cleaner (~> 0.6.0)
email_spec (~> 1.1)
factory_girl_rails (~> 1.0.1)
friendly_id (~> 3.3.0.1)
high_voltage (~> 0.9)
jquery-rails (~> 1.0.0)
- kaminari (~> 0.12.4)
+ kaminari (~> 0.13.0)
launchy
memcache-client
pg (~> 0.10)
- rails (~> 3.1.1)
+ rails (~> 3.2.0)
redis-store (~> 1.0.0.1)
- rspec-rails (~> 2.6.0)
+ rspec-rails (~> 2.8.1)
ruby-debug19 (~> 0.11.6)
- sass-rails (~> 3.1.0)
+ sass-rails (~> 3.2.0)
simple-rss (~> 1.2.3)
simple_form (~> 1.4.0)
sqlite3
View
@@ -48,6 +48,9 @@ class Application < Rails::Application
# config.sass.load_paths ||= []
# config.sass.load_paths << "#{Gem.loaded_specs['compass'].full_gem_path}/frameworks/compass/stylesheets"
+ # Heroku needs this
+ config.assets.initialize_on_precompile = false
+
# load files from the lib directory.
config.autoload_paths += Dir["#{config.root}/lib/**/"]
end

0 comments on commit 92a4333

Please sign in to comment.