Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

drop jeweler dependency.

  • Loading branch information...
commit 8159d321648a793771c85aec50db74973c7df424 1 parent a4c2260
@botandrose authored
Showing with 67 additions and 147 deletions.
  1. +1 −7 Gemfile
  2. +42 −1 Gemfile.lock
  3. +2 −34 Rakefile
  4. +22 −105 bard.gemspec
View
8 Gemfile
@@ -1,9 +1,3 @@
source "http://gemcutter.org"
-group :test, :cucumber do
- gem "rspec", "~>1.3.0"
-end
-
-group :cucumber do
- gem "cucumber"
-end
+gemspec
View
43 Gemfile.lock
@@ -1,7 +1,28 @@
+PATH
+ remote: .
+ specs:
+ bard (0.15.4)
+ bard-rake (>= 0.1.1)
+ capistrano (= 2.5.10)
+ git_remote_branch (>= 0.3.0)
+ grit (= 1.1.1)
+ systemu (>= 1.2.0)
+ term-ansicolor (>= 1.0.3)
+ thor (= 0.11.7)
+ versionomy (>= 0.3.0)
+
GEM
remote: http://gemcutter.org/
specs:
+ bard-rake (0.4.3)
+ blockenspiel (0.4.3)
builder (2.1.2)
+ capistrano (2.5.10)
+ highline
+ net-scp (>= 1.0.0)
+ net-sftp (>= 2.0.0)
+ net-ssh (>= 2.0.14)
+ net-ssh-gateway (>= 1.0.0)
cucumber (0.9.4)
builder (~> 2.1.2)
diff-lcs (~> 1.1.2)
@@ -12,13 +33,33 @@ GEM
gherkin (2.2.9)
json (~> 1.4.6)
term-ansicolor (~> 1.0.5)
+ git_remote_branch (0.3.3)
+ rainbow
+ grit (1.1.1)
+ diff-lcs (>= 1.1.2)
+ mime-types (>= 1.15)
+ highline (1.6.11)
json (1.4.6)
+ mime-types (1.18)
+ net-scp (1.0.4)
+ net-ssh (>= 1.99.1)
+ net-sftp (2.0.5)
+ net-ssh (>= 2.0.9)
+ net-ssh (2.3.0)
+ net-ssh-gateway (1.1.0)
+ net-ssh (>= 1.99.1)
+ rainbow (1.1.3)
rspec (1.3.1)
+ systemu (2.5.0)
term-ansicolor (1.0.5)
+ thor (0.11.7)
+ versionomy (0.4.3)
+ blockenspiel (>= 0.4.3)
PLATFORMS
ruby
DEPENDENCIES
- cucumber
+ bard!
+ cucumber (~> 0.9.0)
rspec (~> 1.3.0)
View
36 Rakefile
@@ -1,37 +1,5 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "bard"
- gem.summary = %Q{Tools for collaborating with Bot and Rose Design.}
- gem.description = %Q{This immaculate work of engineering genius allows mere mortals to collaborate with beings of transcendent intelligence like Micah, Michael, and Nick.}
- gem.email = "info@botandrose.com"
- gem.homepage = "http://github.com/botandrose/bard"
- gem.authors = ["Micah Geisel", "Nick Hogle"]
- gem.add_development_dependency "ruby-debug"
- gem.add_development_dependency "rspec"
- gem.add_development_dependency "cucumber"
- gem.add_dependency(%q<thor>, ["= 0.11.7"])
- gem.add_dependency(%q<capistrano>, ["= 2.5.10"])
- gem.add_dependency(%q<grit>, ["= 1.1.1"])
- gem.add_dependency(%q<git_remote_branch>, [">= 0.3.0"])
- gem.add_dependency(%q<versionomy>, [">= 0.3.0"])
- gem.add_dependency(%q<systemu>, [">= 1.2.0"])
- gem.add_dependency(%q<term-ansicolor>, [">= 1.0.3"])
- gem.add_dependency(%q<bard-rake>, [">= 0.1.1"])
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
-end
-
-task :release do
- system "git push"
- system "git push github"
- Rake::Task["rubygems:release"].invoke
-end
+#!/usr/bin/env rake
+require "bundler/gem_tasks"
require 'spec/rake/spectask'
Spec::Rake::SpecTask.new(:spec) do |spec|
View
127 bard.gemspec
@@ -1,111 +1,28 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
-Gem::Specification.new do |s|
- s.name = "bard"
- s.version = "0.15.3"
+Gem::Specification.new do |gem|
+ gem.authors = ["Micah Geisel", "Nick Hogle"]
+ gem.email = ["micah@botandrose.com"]
+ gem.description = %q{This immaculate work of engineering genius allows mere mortals to collaborate with beings of transcendent intelligence like Micah, Michael, and Nick.}
+ gem.summary = %q{Tools for collaborating with Bot and Rose Design.}
+ gem.homepage = "https://github.com/botandrose/bard"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Micah Geisel", "Nick Hogle"]
- s.date = "2011-12-01"
- s.description = "This immaculate work of engineering genius allows mere mortals to collaborate with beings of transcendent intelligence like Micah, Michael, and Nick."
- s.email = "info@botandrose.com"
- s.executables = ["bard"]
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- ".gitmodules",
- ".rvmrc",
- "Gemfile",
- "Gemfile.lock",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "bard.gemspec",
- "bin/bard",
- "features/bard_check.feature",
- "features/bard_deploy.feature",
- "features/bard_pull.feature",
- "features/bard_push.feature",
- "features/step_definitions/check_steps.rb",
- "features/step_definitions/git_steps.rb",
- "features/step_definitions/global_steps.rb",
- "features/step_definitions/rails_steps.rb",
- "features/step_definitions/submodule_steps.rb",
- "features/support/env.rb",
- "features/support/grit_ext.rb",
- "features/support/io.rb",
- "lib/bard.rb",
- "lib/bard/capistrano.rb",
- "lib/bard/check.rb",
- "lib/bard/error.rb",
- "lib/bard/git.rb",
- "lib/bard/io.rb",
- "lib/bard/ssh_delegation.rb",
- "lib/bard/template.rb",
- "lib/bard/template/adva.rb",
- "lib/bard/template/authlogic.rb",
- "lib/bard/template/compass.rb",
- "lib/bard/template/exception_notifier.rb",
- "lib/bard/template/gems.rb",
- "lib/bard/template/helper.rb",
- "lib/bard/template/initial.rb",
- "lib/bard/template/static_pages.rb",
- "lib/bard/template/testing.rb",
- "spec/bard_spec.rb",
- "spec/spec_helper.rb"
- ]
- s.homepage = "http://github.com/botandrose/bard"
- s.require_paths = ["lib"]
- s.rubygems_version = "1.8.11"
- s.summary = "Tools for collaborating with Bot and Rose Design."
+ gem.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ gem.files = `git ls-files`.split("\n")
+ gem.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ gem.name = "bard"
+ gem.require_paths = ["lib"]
+ gem.version = File.read("VERSION").chomp
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ gem.add_dependency "thor", "0.11.7"
+ gem.add_dependency "capistrano", "2.5.10"
+ gem.add_dependency "grit", "1.1.1"
+ gem.add_dependency "git_remote_branch", ">=0.3.0"
+ gem.add_dependency "versionomy", ">=0.3.0"
+ gem.add_dependency "systemu", ">=1.2.0"
+ gem.add_dependency "term-ansicolor", ">=1.0.3"
+ gem.add_dependency "bard-rake", ">=0.1.1"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<ruby-debug>, [">= 0"])
- s.add_development_dependency(%q<rspec>, [">= 0"])
- s.add_development_dependency(%q<cucumber>, [">= 0"])
- s.add_runtime_dependency(%q<thor>, ["= 0.11.7"])
- s.add_runtime_dependency(%q<capistrano>, ["= 2.5.10"])
- s.add_runtime_dependency(%q<grit>, ["= 1.1.1"])
- s.add_runtime_dependency(%q<git_remote_branch>, [">= 0.3.0"])
- s.add_runtime_dependency(%q<versionomy>, [">= 0.3.0"])
- s.add_runtime_dependency(%q<systemu>, [">= 1.2.0"])
- s.add_runtime_dependency(%q<term-ansicolor>, [">= 1.0.3"])
- s.add_runtime_dependency(%q<bard-rake>, [">= 0.1.1"])
- else
- s.add_dependency(%q<ruby-debug>, [">= 0"])
- s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<cucumber>, [">= 0"])
- s.add_dependency(%q<thor>, ["= 0.11.7"])
- s.add_dependency(%q<capistrano>, ["= 2.5.10"])
- s.add_dependency(%q<grit>, ["= 1.1.1"])
- s.add_dependency(%q<git_remote_branch>, [">= 0.3.0"])
- s.add_dependency(%q<versionomy>, [">= 0.3.0"])
- s.add_dependency(%q<systemu>, [">= 1.2.0"])
- s.add_dependency(%q<term-ansicolor>, [">= 1.0.3"])
- s.add_dependency(%q<bard-rake>, [">= 0.1.1"])
- end
- else
- s.add_dependency(%q<ruby-debug>, [">= 0"])
- s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<cucumber>, [">= 0"])
- s.add_dependency(%q<thor>, ["= 0.11.7"])
- s.add_dependency(%q<capistrano>, ["= 2.5.10"])
- s.add_dependency(%q<grit>, ["= 1.1.1"])
- s.add_dependency(%q<git_remote_branch>, [">= 0.3.0"])
- s.add_dependency(%q<versionomy>, [">= 0.3.0"])
- s.add_dependency(%q<systemu>, [">= 1.2.0"])
- s.add_dependency(%q<term-ansicolor>, [">= 1.0.3"])
- s.add_dependency(%q<bard-rake>, [">= 0.1.1"])
- end
+ gem.add_development_dependency "rspec", "~>1.3.0"
+ gem.add_development_dependency "cucumber", "~>0.9.0"
end
-
Please sign in to comment.
Something went wrong with that request. Please try again.