Flag to not use HTTPS #1350

Open
theRealDrumBum opened this Issue Feb 23, 2013 · 0 comments

Projects

None yet

1 participant

@theRealDrumBum

I am in an ec2 instance where I cannot get SSL support working for python. The quick work around was to turn off certificate verification. Unfortunately, everything is still using HTTPs. Please see below:

aws.py:31 in get_instances_by_tag
30 conn = boto.connect_ec2(aws_key, aws_secret, validate_certs=False)
31 machines = conn.get_all_instances(filters={"tag-key" : tag})
32 # Need to transform the result set into something a bit more useful
python2.7/site-packages/boto/ec2/connection.py:471 in get_all_instances
470 return self.get_list('DescribeInstances', params,
471 [('item', Reservation)], verb='POST')
472
python2.7/site-packages/boto/connection.py:1028 in get_list
1027 parent = self
1028 response = self.make_request(action, params, path, verb)
1029 body = response.read()
python2.7/site-packages/boto/connection.py:974 in make_request
973 http_request.params['Version'] = self.APIVersion
974 return self._mexe(http_request)
975
python2.7/site-packages/boto/connection.py:822 in _mexe
821 i = 0
822 connection = self.get_http_connection(request.host, self.is_secure)
823 while i <= num_retries:
python2.7/site-packages/boto/connection.py:677 in get_http_connection
676 else:
677 return self.new_http_connection(host, is_secure)
678
python2.7/site-packages/boto/connection.py:697 in new_http_connection
696 else:
697 connection = httplib.HTTPSConnection(host,
698 **self.http_connection_kwargs)
exceptions.AttributeError: 'module' object has no attribute 'HTTPSConnection'

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment