Add __future__ import of with_statement for < python2.5 compat #1085

Merged
merged 1 commit into from Oct 29, 2012

2 participants

@staer

After looking through the source it looks like the only two places that use the 'with' statement without a "from future import with_statement" are in glacier. This should take care of those two cases making glacier work from Python2.5 or earlier, Jython, etc.

@jamesls jamesls merged commit 27c6357 into boto:develop Oct 29, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment