Fix travis CI builds for PY3 #3439

Merged
merged 1 commit into from Dec 22, 2015

Projects

None yet

3 participants

@jamesls
Member
jamesls commented Dec 22, 2015

Tracking issue here: travis-ci/travis-ci#5246.
What's happening is that the global boto config on the travis CI
systems is telling boto to load a plugin that is not compatible with
python3.

In the meantime, our workaround is to set the BOTO_CONFIG to some bogus
value so we don't load the global config.

Verified we get a clean run through travis CI.

@jamesls jamesls Fix travis CI builds for PY3
Tracking issue here: travis-ci/travis-ci#5246.
What's happening is that the global boto config on the travis CI
systems is telling boto to load a plugin that is not compatible with
python3.

In the meantime, our workaround is to set the BOTO_CONFIG to some bogus
value so we don't load the global config.
d998021
@ryansydnor
Contributor

+1

Thanks for helping track down the issue so quickly!

@rayluo
Contributor
rayluo commented Dec 22, 2015

Awesome! 🚢

@jamesls
Member
jamesls commented Dec 22, 2015

Fixes #3263

@jamesls jamesls merged commit 22ab610 into boto:develop Dec 22, 2015

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment