Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

conflicting requirements on jmespath between botocore and boto3 #660

Closed
jvehent opened this issue Sep 24, 2015 · 1 comment
Closed

conflicting requirements on jmespath between botocore and boto3 #660

jvehent opened this issue Sep 24, 2015 · 1 comment

Comments

@jvehent
Copy link

@jvehent jvehent commented Sep 24, 2015

While installing boto3 via pip on a fresh centos7 box today, I noticed the following incompatible requirements:

$ sudo pip install -U botocore
Collecting jmespath==0.7.1 (from botocore)
  Using cached jmespath-0.7.1-py2.py3-none-any.whl

$ sudo pip install -U boto3
Collecting jmespath<1.0.0,>=0.6.2 (from boto3)
  Using cached jmespath-0.8.0-py2.py3-none-any.whl

Installing boto3 alone will install jmespath-0.8.0 which is incompatible with botocore. But botocore and boto3 seem to work fine with jmespath-0.7.1.

@kyleknap
Copy link
Member

@kyleknap kyleknap commented Sep 24, 2015

Thanks for reporting. This was reported in #656. We fixed this yesterday with these PRs #658 and boto/boto3#272. Will be available in the next release of botocore and boto3. Closing issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants