Skip to content
Permalink
Browse files

Dropping support for Python2 bc spacy+Python2.7 EOL

  • Loading branch information...
boudinfl committed Apr 16, 2019
1 parent b9425fc commit 86427ebc68bc5c6ae95ae0d4330e257ee9e9a274
Showing with 12 additions and 1 deletion.
  1. +1 −0 .gitignore
  2. +1 −1 .travis.yml
  3. +10 −0 README.md
@@ -5,4 +5,5 @@ docs/build/html/_sources/*
dev/
.pytest_cache/
/venv/
/venv2/
\.idea/
@@ -1,6 +1,6 @@
dist: xenial
language: python
python:
- "2.7"
- "3.7"
# command to install dependencies
install:
@@ -25,6 +25,16 @@ To pip install `pke` from github:
pip install git+https://github.com/boudinfl/pke.git
```

`pke` also requires external resources that can be obtained using:

```bash
python -m nltk.downloader stopwords
python -m nltk.downloader universal_tagset
python -m spacy download en # download the english model
```

As of April 2019, `pke` only supports Python 3.6+.

## Minimal example

`pke` provides a standardized API for extracting keyphrases from a document.

0 comments on commit 86427eb

Please sign in to comment.
You can’t perform that action at this time.