New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Visual Studio 2015 does not find many packages #264

Closed
ElenaLenchic opened this Issue Aug 31, 2016 · 12 comments

Comments

Projects
None yet
6 participants
@ElenaLenchic

ElenaLenchic commented Aug 31, 2016

Hi all,
I have faced an issue that Bower Package Manager for Visual Studio 2015 does not display many of the packages. I.e. (strange exapmle) it displays 'font-awesome', but do not 'fontawesome'. Yet they both reference the same repository.
Another example jquery-easing package is not displayed in Visual Studio. There are a lot of other packages that cannot be found (and installed) through Visual Studio UI.
I have posted a question in social.msdn (https://social.msdn.microsoft.com/Forums/vstudio/en-US/bcf8f403-ac9a-4d3c-8471-a9e2e2ff119e/bower-package-manager-in-visual-studio-2015-does-not-find-bower-packages?forum=visualstudiogeneral). The reply was that is somehow related to compatibility with IE.
I tried to search packages in Edge, but I have got and exception in console:
SCRIPT5009: 'Promise' is undefined
What could be the reason? How to make it work?

@julmot

This comment has been minimized.

Show comment
Hide comment
@julmot

julmot Aug 31, 2016

Member

I'm not using Visual Studio, but maybe someone else @bower/bower-website?

Member

julmot commented Aug 31, 2016

I'm not using Visual Studio, but maybe someone else @bower/bower-website?

@fernandoguedes

This comment has been minimized.

Show comment
Hide comment
@fernandoguedes

fernandoguedes Aug 31, 2016

Contributor

I'm not.

Contributor

fernandoguedes commented Aug 31, 2016

I'm not.

@julmot julmot added the User Support label Sep 1, 2016

@ElenaLenchic

This comment has been minimized.

Show comment
Hide comment
@ElenaLenchic

ElenaLenchic Sep 5, 2016

I have troubles event searching in IE11. Does https://bower.io/search/ supports IE11?

ElenaLenchic commented Sep 5, 2016

I have troubles event searching in IE11. Does https://bower.io/search/ supports IE11?

@benmann

This comment has been minimized.

Show comment
Hide comment
@benmann

benmann Sep 5, 2016

Member

@ElenaLenchic It should.. Can you please be more specific about what you mean by "troubles"?

  • Is there an error on the console?
  • Are there no results returned?
  • Is a request to the server made at all?
  • Are you referring to something visually wrong?
Member

benmann commented Sep 5, 2016

@ElenaLenchic It should.. Can you please be more specific about what you mean by "troubles"?

  • Is there an error on the console?
  • Are there no results returned?
  • Is a request to the server made at all?
  • Are you referring to something visually wrong?
@ElenaLenchic

This comment has been minimized.

Show comment
Hide comment
@ElenaLenchic

ElenaLenchic Sep 5, 2016

I tried to search packages in IE11, but I have got and exception in console:
SCRIPT5009: 'Promise' is undefined
What could be the reason? How to make it work?

ElenaLenchic commented Sep 5, 2016

I tried to search packages in IE11, but I have got and exception in console:
SCRIPT5009: 'Promise' is undefined
What could be the reason? How to make it work?

@riyadhalnur

This comment has been minimized.

Show comment
Hide comment
@riyadhalnur

riyadhalnur Sep 5, 2016

Member

I think we need to use a Promise polyfill. This is a documented problem for IE11. I haven't seen it come up for Edge though.

Member

riyadhalnur commented Sep 5, 2016

I think we need to use a Promise polyfill. This is a documented problem for IE11. I haven't seen it come up for Edge though.

@julmot

This comment has been minimized.

Show comment
Hide comment
@julmot

julmot Sep 6, 2016

Member

@sheerun Seems like you've initially implemented fetch without polyfill. Would it be possible for you to fix this issue?

Member

julmot commented Sep 6, 2016

@sheerun Seems like you've initially implemented fetch without polyfill. Would it be possible for you to fix this issue?

@julmot julmot added bug and removed User Support labels Sep 6, 2016

@sheerun

This comment has been minimized.

Show comment
Hide comment
@sheerun

sheerun Sep 8, 2016

Contributor

I use whatwg-fetch polyfill, see Gruntfile.js

Contributor

sheerun commented Sep 8, 2016

I use whatwg-fetch polyfill, see Gruntfile.js

@ElenaLenchic

This comment has been minimized.

Show comment
Hide comment
@ElenaLenchic

ElenaLenchic Sep 8, 2016

As for IE 11 it is a known issue, this probably causes the problems in Visual Studio. Is there any workaround?

ElenaLenchic commented Sep 8, 2016

As for IE 11 it is a known issue, this probably causes the problems in Visual Studio. Is there any workaround?

@sheerun

This comment has been minimized.

Show comment
Hide comment
@sheerun

sheerun Sep 8, 2016

Contributor

I think the Promise polyfill is missing, I'll fix it asap

Contributor

sheerun commented Sep 8, 2016

I think the Promise polyfill is missing, I'll fix it asap

@sheerun

This comment has been minimized.

Show comment
Hide comment
@sheerun

sheerun Sep 8, 2016

Contributor

Should work now

Contributor

sheerun commented Sep 8, 2016

Should work now

@sheerun sheerun closed this Sep 8, 2016

@ElenaLenchic

This comment has been minimized.

Show comment
Hide comment
@ElenaLenchic

ElenaLenchic Sep 9, 2016

Yes, it works in IE11 and Edge. But for Visual Studio the problem remains the same.

ElenaLenchic commented Sep 9, 2016

Yes, it works in IE11 and Edge. But for Visual Studio the problem remains the same.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment