This repository has been archived by the owner. It is now read-only.
Permalink
Fetching contributors…
Cannot retrieve contributors at this time
88 lines (73 sloc) 1.57 KB
require boxen::environment
require homebrew
/* require gcc */
Exec {
group => 'staff',
logoutput => on_failure,
user => $boxen_user,
path => [
"${boxen::config::home}/rbenv/shims",
"${boxen::config::home}/rbenv/bin",
"${boxen::config::home}/rbenv/plugins/ruby-build/bin",
"${boxen::config::homebrewdir}/bin",
'/usr/bin',
'/bin',
'/usr/sbin',
'/sbin'
],
environment => [
"HOMEBREW_CACHE=${homebrew::config::cachedir}",
"HOME=/Users/${::boxen_user}"
]
}
File {
group => 'staff',
owner => $boxen_user
}
Package {
provider => homebrew,
require => Class['homebrew']
}
Repository {
provider => git,
extra => [
'--recurse-submodules'
],
require => File["${boxen::config::bindir}/boxen-git-credential"],
config => {
'credential.helper' => "${boxen::config::bindir}/boxen-git-credential"
}
}
Service {
provider => ghlaunchd
}
Homebrew::Formula <| |> -> Package <| |>
node default {
# core modules, needed for most things
include dnsmasq
include git
include hub
include nginx
# fail if FDE is not enabled
if $::root_encrypted == 'no' {
fail('Please enable full disk encryption and try again')
}
# node versions
nodejs::version { '0.8': }
nodejs::version { '0.10': }
nodejs::version { '0.12': }
# default ruby versions
ruby::version { '2.4.1': }
# common, useful packages
package {
[
'ack',
'findutils',
'gnu-tar'
]:
}
file { "${boxen::config::srcdir}/our-boxen":
ensure => link,
target => $boxen::config::repodir
}
}