This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Fix `--silent` errors for `ibrarian-puppet`

Following an upgrade to git 2.14.1 I was getting the following error:

```
[Librarian] Git: /usr/bin/git
error: unknown option `silent'
usage: git version [<options>]

    --build-options       also print build options
```

Digging into this I found voxpupuli/librarian-puppet#52 which shows a
fix by including the latest `librarianp` gem. This fixes the issue for
me however more digging into the architecture of `librarian-puppet` will
be required to understand this issue better.
  • Loading branch information...
jacobbednarz committed Aug 31, 2017
1 parent d2accf9 commit d328be906c378c22dbfcc4c7af204cf631095f93
View
@@ -2,8 +2,11 @@ source "https://rubygems.org"
gem "boxen", "~> 2.9.0"
gem "hiera", "~> 1.3.3"
gem "librarian-puppet", "~> 1.0.9"
gem "librarian-puppet"
gem "puppet", "3.7.1"
gem "librarianp",
git: "https://github.com/voxpupuli/librarian.git",
branch: "librarianp"
gem "puppet-lint", "0.3.2"
gem "puppetlabs_spec_helper", "0.4.1"
gem "open4", "~> 1.3.4"
View
@@ -1,3 +1,11 @@
GIT
remote: https://github.com/voxpupuli/librarian.git
revision: 4d78d88be2d7673a136e78760085fbf9664ff27d
branch: librarianp
specs:
librarianp (0.6.3)
thor (~> 0.15)
GEM
remote: https://rubygems.org/
specs:
@@ -28,7 +36,7 @@ GEM
highline (1.6.21)
jmespath (1.0.2)
multi_json (~> 1.0)
json (1.8.3)
json (2.1.0)
json_pure (1.8.2)
librarian (0.1.2)
highline
@@ -91,7 +99,7 @@ GEM
net-ssh (>= 2.7, < 4.0)
net-telnet
sfl
thor (0.19.1)
thor (0.20.0)
PLATFORMS
ruby
@@ -101,7 +109,8 @@ DEPENDENCIES
boxen (~> 2.9.0)
deep_merge (~> 1.0)
hiera (~> 1.3.3)
librarian-puppet (~> 1.0.9)
librarian-puppet
librarianp!
net-ssh
open4 (~> 1.3.4)
puppet (= 3.7.1)
View
Binary file not shown.
View
Binary file not shown.
Binary file not shown.
Binary file not shown.

0 comments on commit d328be9

Please sign in to comment.