No description, website, or topics provided.
Scala
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
planfiles
src
readme.txt

readme.txt

Instructions:

You need Scala 2.9.0 or higher to compile and run the code.

Run /src/plan/Main to run the planner.
Run /src/gui/BasicSwing to run the version with a UI.

The Unit Test stuff under /src/test requires the scala-test library.
The GUI (/src/test) requires the JGraphX java library.
Both libraries can be downloaded freely from the Internet. If you do not have these libraries, 
the two folders can be safely deleted without affecting the main functionality.