New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support multiple versions of Go #11

Open
bradleyfalzon opened this Issue Nov 5, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@bradleyfalzon
Owner

bradleyfalzon commented Nov 5, 2016

As as user, I would like to know which versions of Go my project fails to compile on, so I know the minimum Go version required and if a PR changes (increases or decreases) this.

This would likely work closely with running Go tests #9, as my project may require specific behaviour in later versions (where Go would still compile fine) as opposed to new feature (where older Go versions wouldn't have the same exported types/functions etc).

Users may also like to test against tip, but not have these failures break the build (requires #3).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment