Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Problems with installation #35

Closed
Peace9r opened this Issue Aug 5, 2012 · 4 comments

Comments

Projects
None yet
4 participants

Peace9r commented Aug 5, 2012

I'm running a Debian (Crunchbang - Wheezy) system at home and want to download my Garmin 910XT exercises, however, I'm having trouble installing python-ant-downloader.

Everything installs up until I run "sudo easy_install python-ant-downloader" and then get a long error message with the last part being:

File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 638, in install_item
dists = self.install_eggs(spec, download, tmpdir)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 828, in install_eggs
return self.build_and_install(setup_script, setup_base)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 1105, in build_and_install
self.run_setup(setup_script, setup_base, args)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 1094, in run_setup
run_setup(setup_script, args)
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line 30, in run_setup
lambda: execfile(
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line 72, in run
return func()
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line 32, in
{'file':setup_script, 'name':'main'}
File "setup.py", line 2, in
ImportError: No module named ez_setup

It appears to be a problem with the easy_install command.

Can anyone help?

Owner

braiden commented Aug 5, 2012

Sorry, I think I need to fix installer in newer distro's.

You can manually git clone
git://github.com/braiden/python-ant-downloader.git, and just run
./python-ant-downloader.py

I'm not sure if 910xt works, I think i've had a couple conflicting
reports. Report success failure, and i'll update docs.

If it does not work, then its probably uses the ANT-FS protocol, and
this project may work:

https://github.com/Tigge/Garmin-Forerunner-610-Extractor

Regards,

On Sun, Aug 5, 2012 at 5:48 AM, Peace9r
reply@reply.github.com
wrote:

I'm running a Debian (Crunchbang - Wheezy) system at home and want to download my Garmin 910XT exercises, however, I'm having trouble installing python-ant-downloader.

Everything installs up until I run "sudo easy_install python-ant-downloader" and then get a log error message with the last part being:

[quote]

File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 638, in install_item
dists = self.install_eggs(spec, download, tmpdir)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 828, in install_eggs
return self.build_and_install(setup_script, setup_base)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 1105, in build_and_install
self.run_setup(setup_script, setup_base, args)
File "/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line 1094, in run_setup
run_setup(setup_script, args)
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line 30, in run_setup
lambda: execfile(
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line 72, in run
return func()
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line 32, in
{'file':setup_script, 'name':'main'}
File "setup.py", line 2, in
ImportError: No module named ez_setup
[/quote]

Can anyone help?


Reply to this email directly or view it on GitHub:
#35

Peace9r commented Aug 5, 2012

Thanks,

I managed to install and get the 910 to pair but it doesn't seem to have
downloaded the exercises.

I'll play around with it a bit and see what I can come up with.

Tony
On Aug 5, 2012 11:54 AM, "Braiden Kindt" <
reply@reply.github.com>
wrote:

Sorry, I think I need to fix installer in newer distro's.

You can manually git clone
git://github.com/braiden/python-ant-downloader.git, and just run
./python-ant-downloader.py

I'm not sure if 910xt works, I think i've had a couple conflicting
reports. Report success failure, and i'll update docs.

If it does not work, then its probably uses the ANT-FS protocol, and
this project may work:

https://github.com/Tigge/Garmin-Forerunner-610-Extractor

Regards,

On Sun, Aug 5, 2012 at 5:48 AM, Peace9r
reply@reply.github.com
wrote:

I'm running a Debian (Crunchbang - Wheezy) system at home and want to
download my Garmin 910XT exercises, however, I'm having trouble installing
python-ant-downloader.

Everything installs up until I run "sudo easy_install
python-ant-downloader" and then get a log error message with the last part
being:

[quote]

File
"/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line
638, in install_item
dists = self.install_eggs(spec, download, tmpdir)
File
"/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line
828, in install_eggs
return self.build_and_install(setup_script, setup_base)
File
"/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line
1105, in build_and_install
self.run_setup(setup_script, setup_base, args)
File
"/usr/lib/python2.7/dist-packages/setuptools/command/easy_install.py", line
1094, in run_setup
run_setup(setup_script, args)
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line
30, in run_setup
lambda: execfile(
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line
72, in run
return func()
File "/usr/lib/python2.7/dist-packages/setuptools/sandbox.py", line
32, in
{'file':setup_script, 'name':'main'}
File "setup.py", line 2, in
ImportError: No module named ez_setup
[/quote]

Can anyone help?


Reply to this email directly or view it on GitHub:
#35


Reply to this email directly or view it on GitHub:

#35 (comment)

Contributor

jzacsh commented Dec 23, 2012

I got around this by doing:

sudo easy_install ez_setup

xpayn commented Dec 27, 2012

thx jzacsh! it works like a charm
braiden, you just have to update the easy setup doc to close this issue, you're lucky ;)

@braiden braiden closed this Feb 22, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment