Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 92 lines (86 sloc) 3.157 kB
4cabc1f @brasten Initial sequel-rails commit
authored
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
3 # Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
7 s.name = %q{sequel-rails}
18abe6b @brasten Updated gemspec
authored
8 s.version = "0.1.0"
4cabc1f @brasten Initial sequel-rails commit
authored
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
11 s.authors = ["Brasten Sager (brasten)"]
18abe6b @brasten Updated gemspec
authored
12 s.date = %q{2010-05-18}
4cabc1f @brasten Initial sequel-rails commit
authored
13 s.description = %q{Integrate Sequel with Rails 3}
14 s.email = %q{brasten@gmail.com}
15 s.extra_rdoc_files = [
16 "LICENSE",
17 "README.rdoc"
18 ]
19 s.files = [
20 ".document",
21 ".gitignore",
22 "Gemfile",
23 "LICENSE",
24 "README.rdoc",
25 "Rakefile",
26 "VERSION",
18abe6b @brasten Updated gemspec
authored
27 "autotest/discover.rb",
2e59ee6 @brasten RSpec-related changes
authored
28 "lib/generators/sequel.rb",
29 "lib/generators/sequel/migration/migration_generator.rb",
30 "lib/generators/sequel/migration/templates/migration.rb",
31 "lib/generators/sequel/model/model_generator.rb",
32 "lib/generators/sequel/model/templates/model.rb",
33 "lib/generators/sequel/observer/observer_generator.rb",
34 "lib/generators/sequel/observer/templates/observer.rb",
35 "lib/sequel-rails.rb",
36 "lib/sequel-rails/configuration.rb",
18abe6b @brasten Updated gemspec
authored
37 "lib/sequel-rails/migrations.rb",
2e59ee6 @brasten RSpec-related changes
authored
38 "lib/sequel-rails/railtie.rb",
39 "lib/sequel-rails/railties/benchmarking_mixin.rb",
40 "lib/sequel-rails/railties/controller_runtime.rb",
41 "lib/sequel-rails/railties/database.rake",
42 "lib/sequel-rails/railties/i18n_support.rb",
43 "lib/sequel-rails/railties/log_subscriber.rb",
44 "lib/sequel-rails/session_store.rb",
45 "lib/sequel-rails/setup.rb",
46 "lib/sequel-rails/storage.rb",
47 "sequel-rails.gemspec",
4cabc1f @brasten Initial sequel-rails commit
authored
48 "spec/rcov.opts",
49 "spec/setup_spec.rb",
50 "spec/spec.opts",
51 "spec/spec_helper.rb",
52 "tasks/ci.rake",
53 "tasks/clean.rake",
54 "tasks/metrics.rake",
55 "tasks/spec.rake",
56 "tasks/yard.rake",
57 "tasks/yardstick.rake"
58 ]
59 s.homepage = %q{http://github.com/brasten/sequel-rails}
60 s.rdoc_options = ["--charset=UTF-8"]
61 s.require_paths = ["lib"]
62 s.rubygems_version = %q{1.3.6.1}
63 s.summary = %q{Use Sequel with Rails 3}
64 s.test_files = [
65 "spec/setup_spec.rb",
66 "spec/spec_helper.rb"
67 ]
68
69 if s.respond_to? :specification_version then
70 current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
71 s.specification_version = 3
72
73 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
74 s.add_runtime_dependency(%q<sequel>, ["~> 3.10"])
75 s.add_runtime_dependency(%q<activesupport>, ["~> 3.0.0.beta3"])
76 s.add_runtime_dependency(%q<actionpack>, ["~> 3.0.0.beta3"])
77 s.add_runtime_dependency(%q<railties>, ["~> 3.0.0.beta3"])
78 else
79 s.add_dependency(%q<sequel>, ["~> 3.10"])
80 s.add_dependency(%q<activesupport>, ["~> 3.0.0.beta3"])
81 s.add_dependency(%q<actionpack>, ["~> 3.0.0.beta3"])
82 s.add_dependency(%q<railties>, ["~> 3.0.0.beta3"])
83 end
84 else
85 s.add_dependency(%q<sequel>, ["~> 3.10"])
86 s.add_dependency(%q<activesupport>, ["~> 3.0.0.beta3"])
87 s.add_dependency(%q<actionpack>, ["~> 3.0.0.beta3"])
88 s.add_dependency(%q<railties>, ["~> 3.0.0.beta3"])
89 end
90 end
91
Something went wrong with that request. Please try again.