Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crunchyroll.com doesn't load media unless shields are down #3691

Closed
Brave-Matt opened this Issue Mar 12, 2019 · 2 comments

Comments

3 participants
@Brave-Matt
Copy link
Collaborator

Brave-Matt commented Mar 12, 2019

Description

Tested using Brave v0.60.48 on macOS Mojave (10.4.1)
Anime website crunchroll.com can be loaded and navigated but streaming actual video content fails. Screen/media area stays blank and halts rendering with this in the console:
image

Note that this site does work when using both Beta and Dev channel

Steps to Reproduce

  1. Visit crunchyroll.com with Shields up
  2. Try to watch any video content on the site

Actual result:

Video does not load and playback never starts, appears blank as in the image above

Expected result:

Media playback

Reproduces how often:

Always

Brave version (brave://version info)

Brave v0.60.48 Release

Reproducible on current release:

  • Does it reproduce on brave-browser dev/beta builds?
    No

Website problems only:

  • Does the issue resolve itself when disabling Brave Shields? Yes
  • Is the issue reproducible on the latest version of Chrome? No

Additional Information

Reports:
https://community.brave.com/t/videos-cannot-play-on-crunchyroll-when-browser-is-activated/48297
https://community.brave.com/t/why-i-cant-watch-some-animes-on-crunchyroll-because-of-region-issues/47310/6

@Brave-Matt Brave-Matt added this to To do in Web Compatibility via automation Mar 12, 2019

@kjozwiak

This comment has been minimized.

Copy link
Member

kjozwiak commented Mar 12, 2019

@Brave-Matt does it work under 0.61.51 which is about to be released?

CCing @bbondy as this is a pretty popular streaming website.

@Brave-Matt

This comment has been minimized.

Copy link
Collaborator Author

Brave-Matt commented Mar 15, 2019

@kjozwiak @bbondy Looks like it works in v0.61.51 -- testing on macOS
crunchyroll
Only thing I notice is that you can see it hang just a tiny bit when you watch or skip to a time past where an ad would play.

@bbondy bbondy closed this Mar 15, 2019

Web Compatibility automation moved this from To do to Done Mar 15, 2019

@kjozwiak kjozwiak added the QA/No label Mar 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.