Skip to content
This repository
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

file 74 lines (68 sloc) 2.451 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
from distutils.core import setup
import sys

try:
    import sqlalchemy
except:
    print ''
    print "** SQLAlchemy is recommended, and required for Juno\'s database access"
    print '** Download from: http://sqlalchemy.org/download.html'
    print '** Or run: `easy_install SQLAlchemy`'
    print '** If you\'re not going to be using a database, ignore this.'
    print ''

try:
    import flup
except:
    print ''
    print '** To use SCGI and FastCGI, Juno requires flup'
    print '** Download from: http://trac.saddi.com/flup/'
    print "** If you\'re not going to use SCGI or FastCGI, ignore this message."
    print ''

try:
    import jinja2
except:
    try:
        import mako
    except:
        print ''
        print '** Juno uses Jinja2 or Mako templates by default'
        print '** Using another template library will require additional configuration'
        print '** Download from: http://pypi.python.org/pypi/Jinja2'
        print '** or from: http://pypi.python.org/pypi/Mako'
        print '** Alternatively: `easy_install Jinja2`'
        print '** and: `easy_install Mako`'
        print ''

try:
    import beaker
except:
    print ''
    print '** Beaker is used for Juno\'s session management'
    print '** Download from: http://wiki.pylonshq.com/display/beaker/Home'
    print '** Or run: `easy_install Beaker`'
    print '** If you\'re not going to use sessions, ignore this message.'
    print ''

try:
    import werkzeug
except:
    print ''
    print '** To use the middleware debugger, Juno requires Werkzeug'
    print '** Download from: http://dev.pocoo.org/projects/werkzeug'
    print '** Or run: `easy_install Werkzeug`'
    print '** If you\'re not going to use the debugger, ignore this message.'
    print ''

setup(name = 'Juno',
      description = 'A lightweight Python web framework',
      author = 'Brian Reily',
      author_email = 'brian@brianreily.com',
      url = 'http://brianreily.com/project/juno/',
      version = '0.1.2',
      py_modules = ['juno'],
      classifiers = [
        'Development Status :: 4 - Beta',
        'Intended Audience :: Developers',
        'License :: OSI Approved :: MIT License',
        'Programming Language :: Python',
        'Topic :: Internet :: WWW/HTTP',
        'Topic :: Internet :: WWW/HTTP :: WSGI',
        'Topic :: Software Development :: Libraries :: Application Frameworks',
      ],
     )
Something went wrong with that request. Please try again.