Skip to content
Dart library to encode and decode various archive and compression formats, such as Zip, Tar, GZip, ZLib, and BZip2.
Dart HTML
Branch: master
Clone or download

Files

Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
bin fix dartanalyzer warnings Jan 2, 2020
example fix dartanalyzer warnings Jan 2, 2020
lib clean up analysis warnings Feb 19, 2020
test
web fix dartanalyzer warnings Jan 2, 2020
.gitignore
.travis.yml fix travis build Jan 20, 2019
CHANGELOG.md 2.0.13 Jan 2, 2020
LICENSE bzip2 decoder Feb 5, 2014
README.md 2.0.2 Aug 7, 2018
analysis_options.yaml dartanalyzer work-in-progress Dec 31, 2019
pubspec.yaml 2.0.13 Jan 2, 2020

README.md

archive

Build Status

Overview

A Dart library to encode and decode various archive and compression formats.

The library has no reliance on dart:io, so it can be used for both server and web applications.

The archive library currently supports the following decoders:

  • Zip (Archive)
  • Tar (Archive)
  • ZLib [Inflate decompression]
  • GZip [Inflate decompression]
  • BZip2 [decompression]

And the following encoders:

  • Zip (Archive)
  • Tar (Archive)
  • ZLib [Deflate compression]
  • GZip [Deflate compression]
  • BZip2 [compression]
You can’t perform that action at this time.