Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

QtSystemApplication library detection does not work well for Qt5 #64

Closed
brezerk opened this issue Jan 12, 2016 · 1 comment
Closed

QtSystemApplication library detection does not work well for Qt5 #64

brezerk opened this issue Jan 12, 2016 · 1 comment
Assignees
Labels
Bug

Comments

@brezerk
Copy link
Owner

@brezerk brezerk commented Jan 12, 2016

Even with -DQT5 flag, cmake seems to try to find Qt4 library instead of Qt5 one:

[ himera ] brezerk@pts/7:13  ~/develop/q4wine/build $
cmake .. -DWITH_SYSTEM_SINGLEAPP=ON -DQT5=ON


-- Searching for QtSingleApplication package (WITH_SYSTEM_SINGLEAPP=ON) --

--      library : /usr/lib64/libQtSolutions_SingleApplication-2.6.so
--  include dir : /usr/include/qt4/QtSolutions

@brezerk brezerk added the Bug label Jan 12, 2016
@brezerk brezerk self-assigned this Jan 12, 2016
@brezerk brezerk changed the title QtSystemApplication detection does not work well on Gentoo QtSystemApplication library detection does not work well for Qt5 Jan 12, 2016
@brezerk
Copy link
Owner Author

@brezerk brezerk commented Jan 12, 2016

Fixed: 3c44048

@brezerk brezerk closed this Jan 12, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.