Not connected using this URI postgres://user:pass@localhost:3306/database #254

Closed
alduro opened this Issue Jan 23, 2013 · 5 comments

Projects

None yet

2 participants

@alduro
alduro commented Jan 23, 2013

I'm getting this error when connecting ( using Sequelize as ORM ):
/Users/aldo/Satio/Desarrollo/node/paragon/server/node_modules/pg/lib/connection.js:403
throw new Error("Unrecognized message code " + id);
^
Error: Unrecognized message code 74

URI:
postgres://user:pass@localhost:3306/paragon_development

package.json

{
"name": "app-name",
"version": "0.0.1",
"private": true,
"dependencies": {
"locomotive": "0.3.x",
"express": "3.x.x",
"connect-powered-by": "0.1.x",
"sequelize": "~1.6.0-beta4",
"underscore": "~1.4.3",
"inflect": "~0.3.0",
"ejs": "~0.8.3",
"ejs-locals": "~1.0.2",
"flashify": "~0.1.0",
"pg": "~0.11.3"
},
"engines": {
"node": "0.8.x",
"npm": "1.1.x"
},
"scripts": {
"start": "lcm server --use-nodemon -w"
}
}

Same error if postgresql is running or not.

@brianc
Owner
brianc commented Jan 23, 2013

strange - what version of postgres are you running?

@alduro
alduro commented Jan 23, 2013

9.1.4
installed using Homebrew on Mountain Lion 10.8.2
/usr/local/Cellar/postgresql/9.1.4/bin/postgres -D /usr/local/var/postgres

But it turns out I have the same problem on Heroku.

@alduro
alduro commented Jan 23, 2013

Same on Heroku. Reference code: https://gist.github.com/4605672

@alduro
alduro commented Jan 23, 2013

It turns out the default port is 5432. So I switched port to it and it worked !
I figured that out checking files under /tmp
ll /tmp/.
./ ../ .keystone_install_lock .s.PGSQL.5432 .s.PGSQL.5432.lock

@brianc
Owner
brianc commented Jan 24, 2013

I'm glad it started working for you! Feel free to get in touch if you hit any more snags.a

@brianc brianc closed this Jan 24, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment