Browse files

=Minor tweak to the VERSION constant. Removed the net/ssh/version req…

…uirement and made it into a simple constant. Then made sure the Rakefile correctly uses the version when building the gem. No version bump for this check-in. Still 1.0.2.
  • Loading branch information...
1 parent 68fb7ae commit 45eb45dd094c8c29c345feb1d7785d2f658a9713 @brianvh committed Sep 26, 2009
Showing with 6 additions and 11 deletions.
  1. +2 −0 Rakefile
  2. +3 −10 lib/net/dnd/version.rb
  3. +1 −1 tasks/setup.rb
View
2 Rakefile
@@ -6,10 +6,12 @@ load 'tasks/setup.rb'
ensure_in_path 'lib'
require 'net/dnd'
+require 'net/dnd/version'
task :default => 'spec:specdoc'
PROJ.name = 'net-dnd'
+PROJ.version = Net::DND::VERSION
PROJ.authors = 'Brian V. Hughes'
PROJ.email = 'brianvh@dartmouth.edu'
PROJ.url = 'http://dev.dartmouth.edu/projects/'
View
13 lib/net/dnd/version.rb
@@ -1,18 +1,11 @@
-require 'net/ssh/version'
-
module Net
module DND
- # Describes the current version of the Net::DND library
- class Version < Net::SSH::Version
+
MAJOR = 1
MINOR = 0
- TINY = 2
+ PATCH = 2
- # The current version, as a Version instance
- CURRENT = new(MAJOR, MINOR, TINY)
+ VERSION = [MAJOR, MINOR, PATCH].join(".")
- # The current version, as a String instance
- STRING = CURRENT.to_s
- end
end
end
View
2 tasks/setup.rb
@@ -17,7 +17,7 @@ class OpenStruct; undef :gem; end
:authors => nil,
:email => nil,
:url => "\000",
- :version => ENV['VERSION'] || '1.0.1',
+ :version => ENV['VERSION'] || '0.0.0',
:exclude => %w(tmp$ bak$ ~$ CVS \.DS_Store \.svn/ \.git/ ^pkg/),
:release_name => ENV['RELEASE'],

0 comments on commit 45eb45d

Please sign in to comment.