Permalink
Browse files

minor updates for Catalyst 5.8x

  • Loading branch information...
1 parent 1265ad4 commit de182ea655ff43cc0bc5a5627d1a9d996d1f896e @bricas committed Apr 22, 2009
Showing with 25 additions and 13 deletions.
  1. +4 −4 Makefile.PL
  2. +13 −1 script/cpanhq_create.pl
  3. +5 −5 script/cpanhq_fastcgi.pl
  4. +3 −3 script/cpanhq_server.pl
View
@@ -3,12 +3,12 @@ use inc::Module::Install;
name 'CPANHQ';
all_from 'lib/CPANHQ.pm';
-requires 'Catalyst::Runtime' => '5.7014';
-requires 'Catalyst::Action::RenderView';
+requires 'Catalyst::Runtime' => '5.80001';
+requires 'Catalyst::Action::RenderView' => '0.07';
requires 'Catalyst::Model::DBIC::Schema';
-requires 'Catalyst::Plugin::Authentication';
+requires 'Catalyst::Plugin::Authentication' => '0.100091';
requires 'Catalyst::Plugin::Authorization::ACL';
-requires 'Catalyst::Plugin::ConfigLoader';
+requires 'Catalyst::Plugin::ConfigLoader' => '0.23';
requires 'Catalyst::Plugin::Session';
requires 'Catalyst::Plugin::Static::Simple';
requires 'Catalyst::Plugin::Session::State::Cookie';
View
@@ -4,7 +4,19 @@
use warnings;
use Getopt::Long;
use Pod::Usage;
-use Catalyst::Helper;
+eval "use Catalyst::Helper;";
+
+if ($@) {
+ die <<END;
+To use the Catalyst development tools including catalyst.pl and the
+generated script/myapp_create.pl you need Catalyst::Helper, which is
+part of the Catalyst-Devel distribution. Please install this via a
+vendor package or by running one of -
+
+ perl -MCPAN -e 'install Catalyst::Devel'
+ perl -MCPANPLUS -e 'install Catalyst::Devel'
+END
+}
my $force = 0;
my $mech = 0;
View
@@ -12,7 +12,7 @@
my $help = 0;
my ( $listen, $nproc, $pidfile, $manager, $detach, $keep_stderr );
-
+
GetOptions(
'help|?' => \$help,
'listen|l=s' => \$listen,
@@ -25,10 +25,10 @@
pod2usage(1) if $help;
-CPANHQ->run(
- $listen,
+CPANHQ->run(
+ $listen,
{ nproc => $nproc,
- pidfile => $pidfile,
+ pidfile => $pidfile,
manager => $manager,
detach => $detach,
keep_stderr => $keep_stderr,
@@ -44,7 +44,7 @@ =head1 NAME
=head1 SYNOPSIS
cpanhq_fastcgi.pl [options]
-
+
Options:
-? -help display this help and exits
-l -listen Socket path to listen on
View
@@ -1,10 +1,10 @@
#!/usr/bin/perl -w
-BEGIN {
+BEGIN {
$ENV{CATALYST_ENGINE} ||= 'HTTP';
- $ENV{CATALYST_SCRIPT_GEN} = 31;
+ $ENV{CATALYST_SCRIPT_GEN} = 32;
require Catalyst::Engine::HTTP;
-}
+}
use strict;
use warnings;

0 comments on commit de182ea

Please sign in to comment.